community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

The Designer x64 reported: InboundNamedPipe GetOverlappedResult: The pipe has been ended.

Meteor

Hello everyone,

 

I've moved my Alteryx Designer running on Windows 10 in a VMware Fusion virtual Machine from a MacBook Pro to an iMac Pro (just by copying the Windows VM) and suddenly I'm getting only in some of my workflows the following error when trying to write *.hyper files (*.tde outputs seems to work OK):

 

The Designer x64 reported: InboundNamedPipe GetOverlappedResult: The pipe has been ended.

 

It's really weird because the workflows where running without problems before. BTW I'm the Admin of my Machine, I'm using the following Alteryx's version (because I'm using the Scheduler too, but not for the workflows with the errors):

 

Alteryx Admin Designer

Version 2018.4.5.55178

Running Non-Elevated

 

and my workflows have *xydb inputs that are in a network disk location where I can read/write and my outputs are also in a network disk location where I can read/write.

 

This error is very similar than the ones to be found in another threads but not quite the same so unfortunately I haven't been able to find any help to tackle it. Can I maybe turn on something to catch more details for the error handling?

 

I really appreciate any Feedback, since the error is affecting production workflows.

 

Thanks in advance!

Felipe

Alteryx
Alteryx

Hi @ftorres,

 

Can you please share a screenshot of the data you are trying to extract to Tableau ?
Especially the metadata (data types of the fields in alteryx result window).

 

Thank you in advance

John Gonggrijp-Dowe
Customer Support Engineer
Alteryx, Inc.

I have the same problem. Had a workflow running yesterday and am getting InboundNamedPipe GetOverlappedResult: The pipe has been end now as well. Can neither browse the data nor export it into excel. Although in the last step before on the output view everything seems fine. Screenshots attached. Screen Shot 2019-01-17 at 11.40.02.pngScreen Shot 2019-01-17 at 11.38.00.pngScreen Shot 2019-01-17 at 11.38.16.pngScreen Shot 2019-01-17 at 11.39.40.png

 

 

Screen Shot 2019-01-17 at 11.41.46.png

Fireball

Not sure if this relates to your workflow but I just had this same error with the same behavior that I got results all the way through but nothing in the Browse tools.

 

It seems like it was a strange memory issue with a spatial match for me.

 

I was doing a spatial match with lots of data points compared to a few hundred polygons. I realized that each point is compared to EACH polygon, so each point ended up getting thrown into match or unmatched hundreds of times, each with the universe polygon attached. Not sure if it was a memory issue or if the spatial match didn't like assigning target points to both matched and unmatched?

 

Is there anything in your workflow that exponentially explodes like that?

Meteor

Hi @JohnGD 

 

thank you for your support and sorry I haven't answered before, I was off for couple of weeks.

 

So here are the screenshots you asked me for:

 

Screenshot 2019-03-01 at 09.06.48.png

 

Thank you!

Felipe

Alteryx
Alteryx

Hi @ftorres ,

 

This issue seems to occur when users try to output a hyper file that contains extended ASCII characters (https://www.asciitable.com/) 128-255 as a standard string (v_string or string).

Resolving it implies stripping these characters. This can be done using a Data Cleansing tool or by field type to "vw_string" or "w_string".

 

Could you try it and let me know ?

 

Thank you

John Gonggrijp-Dowe
Customer Support Engineer
Alteryx, Inc.

Meteoroid

@JohnGD 

 

I am getting this error while simply trying to push a csv file to redshift.

The Designer X64 Reported: InboundNamedPipe GetOverlappedResult: The pipe has been ended

It is about 20 lines of data there shouldn't be any issues.

 

Any ideas?

 

Thanks!

Meteoroid

@NMagnussen 

Did you ever resolve this issue?

I had this same error (The Designer x64 reported: InboundNamedPipe GetOverlappedResult: The pipe has been ended) and here is how I was able to fix it. 

 

The problem started when I changed my output file name in a Render Tool using the text box directly, instead of browsing to the folder and typing in the name. In Alteryx, you have two options for entering your output filename, either by entering the full file path as a string, or by navigating to the folder and typing just the name of the output file, selecting the datatype, and clicking Save. in this case I was outputting a Report to an .xlxs, and had changed the output string directly to the same name as an existing file, desiring the Report Output to overwrite the existing file. 

 

I resolved the problem by navigating to the desired folder using the Disc/Save button, then typing in the box, and the error disappeared. Even overwriting an existing report, I had no error. 

 

I hope that helps! 

 

Meteor

Hi @JohnGD,

 

unfortunately the issue still continues even if I change to field type "vw_string" or "w_string". Now even I'm having the issue after a join.

 

Do you think I can contact someone in Germany for giving me some support on the phone?

 

Thank you!

Best

Felipe

Labels