Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Python tool loses code

17 - Castor
17 - Castor

Has anybody else lost their Python code? It has happened to me twice. I go to run my workflow and see that my few hundred lines of code have been deleted and replaced with the standard default:


Alteryx Alumni (Retired)

Hi @etzele,


Could you please contact Alteryx Customer Support ( and precise the following:


  • your exact version of Alteryx Designer and if it is an admin or a non-admin version
  • your version of Windows
  • the full path of your workflow


Kind regards,


Paul Noirel

Sr Customer Support Engineer, Alteryx

13 - Pulsar

Any word on this?

Alteryx Community Team
Alteryx Community Team

The fix for this exact issue was released in Version 2018.4.3.54046. If anyone continues to see an issue similar to this posts issue specifically please reach out to Alteryx Support.



13 - Pulsar


7 - Meteor

Just ran into this issue with the Python tool. Yesterday, I tested both of the workflows that use it (one directly, and one through a macro), and when I view the tool configuration in both cases, it is either empty, or I get a HTTP 404 message.  I am using Designer 2019.1.6.58192 running non-elevated.  Luckily, I pushed my workflows to a repository last night!   I have not changed the code in my Python tool instances in several weeks (the macro code is an exact copy of the direct use of the tool), and this happened for the first time today.

7 - Meteor

To be more specific, I created a complex workflow with a single Python tool, which executed as expected.  Then, I made a copy of that workflow and saved it as a macro.  Then, I deleted the portions of the workflow that I didn't want in my macro, and tested the result using Interface Designer, and then by inclusion in a calling workflow.  Everything worked fine, and I pushed everything to my git repository.  I came to work today, and the original complex workflow worked fine, but the version that I had transformed into a sequence of macro invocations did not.  The Python tool was either not producing any output, or I got the message that the Jupyter server was returning a code of 400 [malformed request].   


I tried copying the Python tool from the working complex workflow to the macro, but that didn't work.  The code of the copy disappeared also.  Finally, I inserted a brand-new Python tool, and copied the code cell by cell from the Python tool original complex workflow.  That worked.  And yes, I will be filing a support issue.

7 - Meteor

This issue persists in Alteryx 2019.1.6???????????????????/

Why can't this tool be removed if alteryx can't make a stable version of it.

A whole month's work is lost now

what the **bleep**

8 - Asteroid



Try opening the .bak file (Workflow backup) created. You may be lucky enough to get the last saved version of the saved code.

Each time a Workflow is save the previous version gets overwritten to the .bak file.This only works if the workflow is not saved after loosing the code


Note :You will have to remove the .bak ext for opening the backup workflow. So you will need to either rename it or copy to a different location

Alteryx Community Team
Alteryx Community Team

@machazthegamer @Nidhin,


I apologize for the miscommunication. The defect was stated to be fixed on our release notes and actually did not get resolved. We are still working on the issue. Please reach out to Support to log your issue with them, so they can pass along to Engineering.



7 - Meteor

I just spent about 45 minutes with an Alteryx Support engineer on this issue.  I was able to show him the problem using Version 2019.1.6.  Two steps that seem to help and may help others are 


1. Resetting User Settings to their default values, ie. unchecking the box that allows you to Override System Settings on the Defaults tab.   My System Settings have always been at their default values.


2. Running in Elevated mode, at least temporarily.


I was unable to recreate the problem after performing these two steps, even after returning to non-Elevated mode.  The problem seems to show cause the following messages in the Jupyter Server log at C:\Users\[my userid]\AppData\Local\Temp: 


[W 15:06:15.718 NotebookApp] 500 PUT /api/contents/9b281e01bf9f3e03c1a1d567a2f6cb0e/66/workbook.ipynb?token=ayx ( Unexpected error while saving file: 9b281e01bf9f3e03c1a1d567a2f6cb0e/66/workbook.ipynb [Errno 2] No such file or directory: 'C:\\Users\\r626481\\AppData\\Local\\Temp\\9b281e01bf9f3e03c1a1d567a2f6cb0e\\66\\workbook.ipynb'
[W 15:06:15.719 NotebookApp] Unexpected error while saving file: 9b281e01bf9f3e03c1a1d567a2f6cb0e/66/workbook.ipynb [Errno 2] No such file or directory: 'C:\\Users\\r626481\\AppData\\Local\\Temp\\9b281e01bf9f3e03c1a1d567a2f6cb0e\\66\\workbook.ipynb'