Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Filtering Out A BLOB Causes an Error

9 - Comet

I created a workflow that passes a database table name through a text input, dynamic input to modify the sql, return 1 record and process it to get the field names, data types, etc and marries it up to a data dictionary table for system descriptions. A quick painless process.


All was good until I ran into tables that have a BLOB as a data type.


Workflow started failing. Did a little investigation and found those BLOBs were not needed to go through the process so I thought adding a simple filter would do the trick.  Everything I tried failed to filter.... and an error would appear that BLOBs can not be filtered.


The temp remedy  - I had to add a select, find the field, and deselect it.


Any thoughts would be greatly appreciated.



19 - Altair
19 - Altair

Hi @stapuff 


Depending on the flavour of SQL that your running your queries against, have you considered querying the  "INFORMATION_SCHEMA" tables (T-QSL) or "all_tables" and "all_tab_columns" (Oracle) or the equivalent.  These return text information about the tables and columns so you won't have any blob issues 




9 - Comet



I got up at 2 a.m. with that exact idea. Remove it using the Table Schema. Been doing it in Excel with VBA for what seems like a 100 years now against a different system.  Moved from AS400 to SAP and it was like I had amnesia for the last 20 years.


Thanks for the response.  I appreciate it and your time.



7 - Meteor

Can you share any example workflows? I'm stuck on the same issue with blob!