SDK Resources

Explore these resources to customize and extend the power of Alteryx with SDKs, APIs, and more.

Alteryx Connectors and Tools for 24.1

baileykaplan
Moderator
Moderator
Created

Introduction

The Python Upgrade is a product initiative that will take Alteryx from using Python v3.8.16 in Designer and Server to v3.10.13. This is because Python is ending  support for v3.8 and Alteryx must follow suit to stay compliant with security measures. Security is paramount at Alteryx, and we must have Designer upgraded to Python 3.10 by the 2024.1 release (early May 2024). We recommend reading this FAQ before implementing updated versions of specific tools.

This document specifically talks about Alteryx-built Python Tools, and how to implement versions of them that are compatible for Designer and Server 24.1. These tools include Data Connectors (formerly available on Community, now available on the Alteryx Marketplace), AIS Tools, and the Enterprise Utility Tools.

Data Connectors

Tool

Status/ Anticipated Ready Date
Note: These are estimates and are subject to change.

Google Analytics 4

Ready

SharePoint Tools

Ready

Tableau Tools

Ready

Dataverse Tools

Ready

Outlook 365 Input Tool

Ready

Salesforce Tools

Ready

Google Drive Tools

Ready

Box Tools

Ready

PowerBI Output Tool

Ready

ServiceNow Tool

Mid-June

OneDrive Tools

Mid-June

Azure Data Lake Tool

Mid-June

UiPath Tool

Mid-June

Anaplan Tools

Ready

Power Automate Tool

End of June

Automation Anywhere 360 Tools *

DEPRECATE

DropBox Tools *

DEPRECATE

*If you are using any of the deprecated tools, we advise you not to upgrade.

Instructions for Updating Data Connectors

First, make sure Alteryx Designer and Server Version 2024.1 (or later) is installed on your system. The official release of Designer and Server 24.1 is planned for early May, but a Beta version of Designer 24.1 is available via Public Preview.

In Designer and Server 2024.1, the workflows using outdated versions of these connectors will return one of the following errors:

This tool uses Python version 3.8. Please install an updated tool YXI that uses Python 3.10 for Designer 24.1 and later.

or

Version 3.10 was not found in our alteryx distribution. Please select another version.

This error indicates that you are using a Connector or Tool that uses Python v3.8 in Designer 2024.1 or later, which is only compatible with Python v3.10.13. Follow the steps below to update the Data Connector to a compatible version with Designer 24.1.

We'll be releasing new installation files of the impacted connectors with the same version number and the updated Python version.

To fix this error and update your connectors, follow these steps.

  1. Go to the Alteryx Marketplace.

  2. Select All Add-Ons > Connectors.

  3. In the Designer Version filter, select 2024.1.

  4. Select the connector you want to upgrade.

  5. The connector page displays an overview. Select the Editions tab.

  6. Select the Get Add-On of the Designer 2024.1 build.google analytics.png
  7. The Alteryx Marketplace displays your Applications page. Select the connector you want to upgrade.

  8. On the connector page, select the Download Files tab.

  9. Select the Download button of the build compatible with Designer 2024.1.

  10. Open the downloaded file. For Server, you need to install the connector as an administrator.

  11. Select the Install button in Designer. The installation may take several minutes to complete.

  12. Once the installation completes, you don’t need to manually swap the tools because the workflows will use the updated connectors automatically.

If the new updated build of the data connector you use isn’t yet available for Designer and Server 2024.1, we recommend staying on your current version of Designer and checking back regularly for updates.

Designer Desktop Add-Ons

You can also look for the updated tools directly in Designer by going to the new menu option Add-Ons > Manage Marketplace Add-Ons.

Look for the needed tool to download and install to use immediately in Designer.

Note: This feature is in Beta and the Update functionality may be visible, but it is not functional at this time. To update a tool follow the instructions above regarding the Alteryx Marketplace.

designer marketplace.png

Please note that Marketplace Add-Ons will also show Connectors that have not been updated yet for 2024.1.
Before downloading Connectors please confirm their compatibility with Designer 2024.1 in the table above.

Select the Most Recent Version of the Connector

If you’ve set up an older version of a connector in your workflow, you must select the most recent one manually. After you’ve installed the updated build, right-click the connector icon on your workflow canvas, hover over Choose Tool Version, and select the most recent version. You might need to configure the connector again.

Alteryx Intelligence Suite Tools

This includes ML Tools, Computer Vision Tools, and Text Mining Tools.

Instructions for Updating AIS Tools

First, make sure Alteryx Designer and Server Version 2024.1 (or later) is installed on your system. The official release of Designer and Server 24.1 is planned for early May, but a Beta version of Designer 24.1 is available via Public Preview.

Navigate to Flexera and download the YXI for ML Send and ML Predict.

If you are upgrading to 24.1 directly from 23.2 or earlier, you will need to delete the old tools and replace them with the new ones.

However, due a versioning update released as a patch in May of 2024, if you upgrade to this patch of your current release, and then later upgrade to 24.1, the process is simpler. In this case, you only need to install the latest version of the tools and then select the correct tool version.

Run this workflow to make sure everything works as expected. Save the workflow to make sure your changes are updated.

Additional AIS Tool Information

  • Classification and Regression Tools: Removed the Presort parameter from the Advanced Parameters section of the Decision Tree algorithm.

  • Predict Tool: Some models created before AIS 2021.4 might not work with the Predict tool. Additionally, models created with the AutoML tool are no longer supported. Please use the Assisted Modeling tool to build your machine learning model.

Comments
ko
Alteryx
Alteryx

Error message looks like this when new Tool is run on the old Designer.

Version 3.10 was not found in our alteryx distribution. Please select another version.
Internal Error - Deadlock detected (@1)

Chemisky
5 - Atom

Hi, do you have any news on the release dates for Salesforce tools for Alteryx24.1 ?

 

 

SFA tools.PNG

aaalice
5 - Atom

How about downgrading to run the Tool on old Designer? I'm also getting this error:

Version 3.10 was not found in our alteryx distribution. Please select another version.
Internal Error - Deadlock detected (@1)

jenny17
5 - Atom

The new SF tool is still not working. If you have the old SF tool and the old version of Alteryx Designer, that should work perfectly on your end. But if you are using the latest SF tool with the latest version of Alteryx Designer, there are still some issues. Though the latest SF tool is revised and updated, there are some issue. My Alteryx rep confirmed the issue today at 2:32 pm cst.

 

"I've tested the tool in the 2024.1 version still there are some errors. I'm working with my dev team on this I'll keep you posted on the progress."