Welcome to the Gallery. Please feel free to post and comment, and check out our FAQ!

Community Gallery

Post, download, and share all of your favorite tools and workflows — from Alteryx supported to user-built.
Comments
Landon_Holbrook
5 - Atom

Hi,

 

Do you know what this error means? 

 

Landon_Holbrook_0-1644345785116.png

 

r4upadhye
11 - Bolide

Works well, thanks.

helpfultoaster
Alteryx
Alteryx

@Landon_HolbrookThat looks like an install error that could be related to network/anti-virus restrictions. Please reach out to Customer Support for a pre-installed copy of the tool.

jasonreadcox
5 - Atom

Alteryx Designer Version: 2021.3.2.54175

 

I cannot authenticate successfully. The "Connect" process appears to work as expected but after I have supplied my credentials (including MFA), I am left with only a blank floating window and the tool does not recognize that the login was successful. Here are screenshots of the process and result:

 

1. Screen Shot 2022-02-24 at 2.49.00 PM.png

 

2. Screen Shot 2022-02-24 at 2.49.21 PM.png

 

3. Screen Shot 2022-02-24 at 2.49.56 PM.png

 

4. Screen Shot 2022-02-24 at 2.50.53 PM.png

 

5. Screen Shot 2022-02-24 at 2.51.07 PM.png

 

6. The source of this blank html page is:

Screen Shot 2022-02-24 at 2.51.31 PM.png

 

I've also set up an app in Azure according to instructions here https://help.alteryx.com/20214/designer/microsoft-outlook-365 and I end up with the same blank window despite an apparent successful authentication.

 

Any ideas what I am doing wrong?  I believe I've eliminated all potential firewall and antivirus culprits.  We aren't using a proxy...  

mjackey
5 - Atom

Any update on the blank screen after authentication?
Today we updated to version Version: 2021.3.3.63061.  In the old version this was working and it stopped working after the update.

jasonreadcox
5 - Atom

@mjackey - Unfortunately no.  I haven't heard from anyone about this and I am still having the same problem.

mjackey
5 - Atom

@jasonreadcox Thanks for the reply.

 

In this post near the bottom rpaugh says that it is a bug in the version of alteryx and to upgrade or downgrade to get it to work which makes sense because it was working before we upgraded today.

https://community.alteryx.com/t5/Public-Community-Gallery/Outlook-Input-Tool/ta-p/883455

 

jasonreadcox
5 - Atom

@mjackey - Which version were you running when it worked?  Its never worked for me so I don't know what version to downgrade to.  I am running 2021.3.2.54175 currently.

mjackey
5 - Atom

@jasonreadcox 2020.2.3.27789

taxguy33
8 - Asteroid

Alteryx Designer Version: 2021.4.2.02731

 

I cannot authenticate successfully (the error message on the tool says only "Failed to Authenticate". Unlike @jasonreadcox 's issue where he got the "Blank Floating Window (I was getting that on @rpaugh 's latest public gallery version of his O365 tool with no resolution), I seem to connect to my O365 account properly (using the Internet Browser option) after entering in credentials and completing MFA. As you can see - the tool is connect to my Inbox and my Shared Mailbox accounts (you can see the subfolders in my Alteryx shared mailbox) - but all I get is the "Failed to Authenticate" issue when running the tool.

 

Has anyone run into this and how did you get past it? Did you have to get company IT involved to unblock anything (not even sure where to start on that)? Or did you go straight to the Azure app option?

 

Error message plus screenshot showing a connection to O365 has been established. Very vague about what is occurring falteringError message plus screenshot showing a connection to O365 has been established. Very vague about what is occurring faltering

taxguy33
8 - Asteroid

I am getting this image saying the Refresh Token is expired and is only allowed to work for 24 hrs before it needs refreshed. Does anyone know how to extend this setting? It is really burdensome to have to refresh these tokens every day - would love to have it be 90 days or more. If I went down the "Provide Client ID, Client Secret and Tenant ID" route - would I be able to extend the life of this token instead of the "Sign In via Internet Browser" that seems to limit to 90 days?

 

Thanks!

 

taxguy33_0-1649878899076.png

 

davidhe
Alteryx
Alteryx

@taxguy33 you're going to want to leverage the Azure app registration route. 

QuantumViridis
7 - Meteor

@davidhe

I am using the Azure app registration route and have the same problem.  Since I am running the workflow on my server, reconnecting daily is not feasible.  Is there a solution?

QuantumViridis_0-1653501024048.png

 

Paul_Holden
8 - Asteroid

Is it possible to publish workflows using this tool to the Gallery?

 

If so how is authentication managed for unattended (scheduled) runs?

 

[EDIT]

Ah, okay, I came here from this page...

 

https://help.alteryx.com/20221/designer/outlook-365-input-tool

 

But I now see that the help page in the tool description is different...

 

https://help.alteryx.com/20221/designer/microsoft-outlook-365

 

What I'm not clear on is exactly how these two sets of information relate to each other and exactly what I need to tell our users they need to build in order to keep the workflows that were running fine under on-prem Exchange working for O365.

 

Sorry if I'm being dumb here, any help appreciated.

mfresques
6 - Meteoroid

 

@davidhe, @taxguy33  I'm running into the same problem with having to refresh the token every 24hrs.  Did you ever get this resolved?  

mfresques_0-1658169557296.png

 

taxguy33
8 - Asteroid

Yes, I followed @davidhe  advice and went down the Azure app registration process and created a "client secret token" for 6 months and have had 0 issues thus far. It did take a little back and forth with the IT team to make sure the calls to this app were not being blocked by our firewalls, but smooth sailing after this convo.

mfresques
6 - Meteoroid

@taxguy33  I've generated a client secret token but now the outlook tool is failing to authenticate.  Did you get this error when you had the firewall issue? 

Wrigh6s
5 - Atom

Anyone else having issues downloading the file? Gets to 18Mb then stops and says server issues?

davidhe
Alteryx
Alteryx

great to hear @taxguy33 !

hornungr
7 - Meteor

This connector is definitely a step in the right direction, but is it correct to say that the only way it will work on the gallery is if our IT group registers an Azure app (with service principal)?  And from what I understand, an Azure App would have to be registered for each user since the service principal approach would explicitly grant privileges to certain mailbox(es).  It would not delegate or impersonate privileges based on the Alteryx user.

 

What I'd like to see is for this connector to act more like the Power BI output tool.  In that case, there was a 'pre built' azure app for the Alteryx to Power BI connection that had to be approved by our O365 tenant admin one time.  From there anyone that used the add-in and would only see what their own O365 account is privy to...I've heard this described as the 'delegation' feature.  Another bonus with this approach is there's no client id/secret required.

 

Before submitting this as an 'idea', I wanted to make sure what I described is correct.  Has anyone gotten this add-in to work in the gallery for multiple users without having to register an azure app for each user to use with their email account (or without having them share a single client id/secret that's privy to all accounts...definitely not an option for us)?

JadeB
5 - Atom

Having trouble downloading the tool. Does anyone know what this error means?

JadeB_1-1665485670044.png

 

Paul_Holden
8 - Asteroid

Hi,

 

Cross posted from the thread on installing tools for workflows running on server - apologies if that's not allowed.

 

https://community.alteryx.com/t5/Alteryx-Server-Knowledge-Base/Error-Unable-to-resolve-plugin-Python...

 

My users are getting the following error when they publish workflows to the server:

 

Unable to resolve plugin Python 'Outlook365Inputv1.0.0\main.py'

 

I have installed the Outlook tool on the server in Designer using the service account which is a member of the local administrators group for the server.

I have installed the Outlook tool on the server running Designer as admin and selecting "Install for all" via my personal domain account which is a member of the local administrators group for the server.

I have restarted the alteryx service

I have restarted the server (Windows o/s restart)

 

Any ideas gratefully accepted.

 

[EDIT]

To me this seems to be either authorisation or path issues preventing the workflow from accessing/finding the python module?

 

Right now I'm focusing on the install location. Our server setting for Global workspace is D:\AlteryxProgramData

 

But the tool has been installed to C:\ProgramData\Alteryx\Tools

 

I'm looking for more information as to where the workers look for tool code as I can't find any way so far to control where the tool gets installed.

 

Thanks

Paul

Paul_Holden
8 - Asteroid

I finally figured this out as I was able to add the tool in Designer on the server to a workflow where the existing tools were not showing/working correctly.

 

I checked the XML and only then noticed that my users have

 

Outlook365Input_v1.0.0

 

Whereas on the server I have installed

 

Outlook365Input_v1.1.0

 

I'm slightly annoyed that the plugin methodology for this means that we have to replace all of the tools in the already created workflows to get this working but it is what it is.

hornungr
7 - Meteor

@Paul_Holden - Glad you got your issue fixed.  I'd be curious if you've had much success using the new Outlook 365 tool on a gallery server.  We ran into issues (with the v1.0.0 connector) where it would run fine on the gallery after initial publish but the token would then expire the next day.  After opening a support case we found that the connection must use a service principal account with client id/secret to avoid this problem.

We've since worked with our tenant admins to setup the service principal (with client secret specified in the connection) but haven't had much getting it to work thus far...even just from the designer client.  Wondering if you took this approach & have had any luck running from the gallery server?

Paul_Holden
8 - Asteroid

@hornungr this is exactly my next challenge.

 

We faced a similar challenge with the previous community version of the tool from @rpaugh (thanks again for all the work on that previous tool) and in the end we decided to run the required workflow from Designer since it is only used by a team which includes an embedded Alteryx developer. We don't see this as sustainable going forwards, and we expect more demand for this tool going forwards, hence we are now trying to get it running on the server as part of our upgrade to 2022v1.

hornungr
7 - Meteor

UPDATE:  We noticed version 1.1.0 was released a few weeks ago with a slight update to the general Outlook 365 tool page to include this statement: "You can use the default Alteryx application (Sign in via Internet Browser) to schedule workflows for up to 6 months.".

 

Without a lot of fanfare, it appears that Alteryx released an update that no longer requires registering an Azure App (nor svc principal) to schedule on the gallery.  Although I really wish Alteryx would've advertised this better on community threads like this, it does seem to solve a lot of problems for us!

Paul_Holden
8 - Asteroid

@hornungr  I saw that as well but I'm not really clear what it means.

 

"You can use the default Alteryx application (Sign in via Internet Browser) to schedule workflows for up to 6 months.".

 

...is this saying to run a workflow in Designer on the worker (? Controller?) and the generated token will be valid for 6 months for all jobs?

hornungr
7 - Meteor

@Paul_Holden-  We're able to simply publish a workflow from designer (running on the client machine, not worker) and the workflow executes successfully on the gallery beyond the 24-hour token expiration we had previously run into.  And this is using the standard browser auth option in designer; no client, secret or service principal required.

As far as what we'll need to do after 60 days, I'm not sure yet but would assume the workflow will have to be republished to establish the new token.

Paul_Holden
8 - Asteroid

@hornungr  thank you so much. I just have not had the time to test this (also I don't write workflows myself so I rely on being able to get some developer time for testing) so this is a huge help to me.

Jafar
5 - Atom

I have downloaded and configured the tool.

However, when I execute it with using Data Option i.e. (Check - Download attachments from emails), getting an error "Error: Outlook 365 Input (1): Failed to fetch emails data. Check your settings and try again."

When I untick the option I am not getting any error.

I need to alteryx to read the attachments and display the result for CSV/Excel.

 

Jafar_0-1668585266890.png



 

Paul_Holden
8 - Asteroid

@Jafar 

 

Have you checked the mailbox permissions with your Exchange team?

I don't know how granular they are but you may find that whilst your account has permissions to view the mailbox it doesn't have permissions to download attachments?

 

Disclaimer: I am not an Exchange admin so this might be rubbish!

 

Regards,

Paul

VijayGopal
5 - Atom

Hi All,

 

I also ran into same issue, any has solution for this.

 

VijayGopal_0-1669731196851.png