community
cancel
Showing results for 
Search instead for 
Did you mean: 

Dev Space

Customize & extend the power of Alteryx. SDKs, APIs, custom tools, and more!
SOLVED

2018.3 installing python tool - Cache entry deserialization field, entry ignored

Highlighted
Comet

Hi all,

 

I was very excited to upgrade to 2018.3 last night - and still am! - because of caching and the new python tool :)

 

But this morning I've hit two errors when importing a tool that I have previously imported into 2018.2 version without errors.

 

8-31-2018 9-24-02 AM.png

 

 

 

 

 

 

 

This first error was an easy fix, just noting the difference in the file name requirement.

 

8-31-2018 9-26-08 AM.png

 

 

 

 

 

 

 

This second error, I'm not sure how to resolve. It locked up my Alteryx session and I had to force quit. I tried to import the tool twice (non-admin, once as admin) with the same error. I have Version 2018.3.4.51585, Admin install, and tried installing the tool both non-elevated and elevated (admin).

Alteryx
Alteryx

Try deleting your pip cache directory. The directory location is <CSIDL_LOCAL_APPDATA>\pip\Cache so it's probably  C:\Users\{user}\AppData\Local\pip for you.

Comet

Thanks @RithiS! This resulted in a timeout message connecting to pypi.python.org which reminded me that pip is blocked by my company DNS. So I disconnected from VPN to try again and it worked!

 

So I'm not sure whether the initial error was also caused by the inability to compare the cache to the pip server.