Community Gallery

Create, download, and share user-built tools and workflows.
Looking for Alteryx built Add-Ons?

Easily shop verified, supported, and secure Partner and Alteryx built Add-Ons on Marketplace.

LEARN MORE
Comments
Mausam
8 - Asteroid

Hi,

I am getting an error:

"Tool Install Error: JupyterFlow_0.2.yxi is not a supported Install type."

JupyterFlowError.PNG

JeffA
Alteryx Alumni (Retired)

@Mausam Hello!
Just need to make sure you've got Alteryx 2020.4 or later installed, according to https://community.alteryx.com/t5/Data-Science/Jupyter-Flow-Basics-Guide/ba-p/778947

If so, could you tell me what version of Alteryx is installed?

DMavr
5 - Atom

Hi, 

 

I am getting an error:

 

DMavr_0-1649235103958.png

 

I am running Alteryx as an administrator (Version: 2021.3.1.47945)

 

Wondering if someone knows of a fix? 

Thanks

 

lerick15
5 - Atom

@DMavr, were you able to find a solution to your error message? I'm getting the same one. 

version: 2021.4.2

 

Thanks

natalie_ubs
5 - Atom

When trying to download, I get a "File wasn't available on site" error. Its not an error with my organization or firewalls because the OpenAI Connector package was downloaded no problem

Capture.PNG

 

 

4kammer4
5 - Atom

Hi, thanks in advance for the help.

 

ResolutionImpossible error.

PythonResolutionImpossible.png

 

vincentghyim
5 - Atom

Hi there, I tried installing the tool but encountered the same ResolutionImpossible error as 4kammer4 above:

https://community.alteryx.com/t5/Community-Gallery/Jupyter-Flow/tac-p/1211453/highlight/true#M1811

 

I had a look at the C:\Users\<UserName>\AppData\Roaming\Alteryx\Tools\JupyterFlow folder created during installation, and I suspect the error is to do with the pinned versions of the packages in the requirements-thirdparty.txt file:

 

ayx-plugin-sdk==0.1b4
ayx-python-sdk==1.0.1
Click==7.1.2
comment-parser==1.2.3
fastcore==1.3.4
grpcio==1.28.1
grpcio-tools==1.28.1
joblib==0.17.0
jupyter==1.0.0
numpy==1.19.1
pandas==1.1.0
papermill==2.3.3
parso==0.8.1
protobuf==3.17.3
psutil==5.6.3
pyarrow==4.0.0
pydantic==1.5.1
python-dateutil==2.8.1
pytz==2020.1
regex==2020.10.11
setuptools==46.1.3
shiv==0.3.1
six==1.14.0
tqdm==4.50.2
typer==0.3.1
xmltodict==0.12.0
msvc_runtime==14.29.30133

 

It seems likely that one or more of these packages have conflicting version requirements. Is there any planned solution or current workarounds to this issue?

 

---

Update:

 

Found this in the PythonDependencyInstall.log file:

 

2024-02-14T13:17:38,389 ERROR: Cannot install -r requirements.txt (line 5) and papermill==2.3.3 because these package versions have conflicting dependencies.
2024-02-14T13:17:38,391
2024-02-14T13:17:38,391 The conflict is caused by:
2024-02-14T13:17:38,391 The user requested papermill==2.3.3
2024-02-14T13:17:38,391 moonbuggy-toolkit 2020.4.0.dev0 depends on papermill==2.2.2
2024-02-14T13:17:38,391
2024-02-14T13:17:38,391 To fix this you could try to:
2024-02-14T13:17:38,391 1. loosen the range of package versions you've specified
2024-02-14T13:17:38,391 2. remove package versions to allow pip attempt to solve the dependency conflict

It looks like this is because moonbuggy-toolkit depends a specific older version of papermill. Unfortunately I can't find moonbuggy-toolkit on PyPI: https://pypi.org/search/?q=moonbuggy-toolkit

tristank
11 - Bolide

Does anyone know if this tool is still getting support or has it been deprecated?