community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

why doesn't render output show in gallery?

Highlighted
Comet

I am new to Alteryx Server. When I run the analytic app in Designer, I see the render output, but when I run it in Server, it says "no output." I have the Render tool configured for "Temporary PDF Document." I also tried "Temporary Composer File," but got the same result.

 

Based on other related posts, it looks like this should work. I suspect it is something in how our server is configured. Any help would be appreciated.

 

Great question! It used to work, but they made a switch in version 10.1. To display your render tool output, you will need to select the last output mode:choose a specific output file. You can then output a file like "temporary.pdf" or "temporary.pcxml" for pdfs or composer files. We brought this change up to some folks at Alterx and their response included this: "Usage of %temp%, or writing to any location that is considered “temporary” (ex. temporary report output files) when building workflows for execution in a server/gallery is not a recommended practice, and will indeed fail and cause odd behavior."

 

Hope that helps!

Comet

Thank you very much for your reply. However, I just tried setting it to a UNC path which is available to everyone in our organization, with a fixed filename, and got the same result. Any more ideas?

 

Is there some document that details this that I have not been able to find? The Help about the Render tool certainly doesn't mention it.

 

I am running version 10.5.

 

Thanks again!

 

I haven't been able to get UNC files to display either :smileyfrustrated: I think your 2 options for display would be to 1) make it a relative reference by just providing the filename "testfile.pdf" and that will be displayed. or 2) keep your unc path in there and when uploading to the server be sure to click manage workflow assets and check the box for your output so that it gets packaged up. It should display your results in both of those cases.

 

The documents don't exist to my knowledge with the level of technical details that I would like to see. We've been pointed to the app building guidelines https://gallery.alteryx.com/static/AppBuildingGuidelines.pdf and the help files http://help.alteryx.com/10.1/index.htm#TempFiles.htm

Comet

Thank you! Just removing the UNC path, allowing the relative reference worked for me.

 

Also, thank you for that reference to the "App Building Guidelines." That is a valuable doc I hadn't found previously.

 

Much appreciated.

Asteroid

@patrick_digan 

Thanks for providing the link to the App Building Guidelines.  It has been very helpful.

 

I have an app that I run from Alteryx Designer.  It has a folder browse tool.  This allows the app user to select the folder containing data files to be processed by the app.  Since the folder browse tool is not supported in the gallery, can you suggest a work around?  

 

Thanks,

papalow

@papalow  We've just used a text box tool and had people copy and paste network locations. Our apps would convert the drive letter (J:) to UNC (\\domain.com\Groupfolders\) and make sure that our service account running the jobs has access the appropriate network locations.

Asteroid

@patrick_digan 

Thanks for sharing that idea.  That would probably be a betters solution than using a static folder to temporarily house data files that the app consumes.