Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

error while saving workflow in Gallery: RuntimeError: Internal Error: DecryptPassword -

7 - Meteor

Dear all,


My App works in Desktop but when I try to save it in Gallery, I have the following errors for 2 Salesforce Input Tools: 


Traceback (most recent call last): File "", line 71 in pi_init

RuntimeError: Internal Error: DecryptPassword - buffer too small


if I bypass the error messages, I can save my App but when I run it, I get the error messages back and con't complete the Run.


Could you help?



5 - Atom

Has this been fixed?  Salesforce is a dominate force in the CRM/CPQ...industry and this connector will become more & more important to Alteryx users.   I can get this working in Designer, both simple workflows and complex macros.  However, I can't save or run any workflow to the server because of this bug.     




7 - Meteor

Apologies for the late answer. The issue came from an old version of the SF connector while I was using a new Alteryx version. It is fixed by using the new SF connector version.



5 - Atom

Hi Nicolas - do you happen to know which version you were working from/ moved to?

8 - Asteroid

HI Nicolas,

I understand your answer to mean that you have a newer version of the SF Connector on your local machine and an older version of SF Connector on your Alteryx Server?

I have same problem after upgrading my local Designer to 2020.4 which now uses Python 3.8, while our Alteryx Server which recently upgraded to 2020.4 seems not to have upgraded and uses the SF Input Tool v4.1.0 but based on Python 3.6.

Thanks for any further insight you can offer.


7 - Meteor

Hello @NicolasDestombes


I am getting exactly same issue as you have mentioned. I have Designer 2020.3 in local laptop and Server 2020.3 on remote server with same Salesforce Input tool v4.1.0.

My original workflow was build using Server Designer on the server and published to Alteryx Gallery, no issues there and workflow is scheduled to run every day, everything is working fine.

BUT, today i installed local Designer 2020.3 (same version) on my laptop and opened the workflow from Alteryx Gallery (the original workflow which was build using Server Designer) and when im running it is giving exactly the same error as you mentioned, although the versions for both designer and salesforce input tools are same.


i tried to make a POC (on my local designer), connecting with Salesforce using Input tool, configured the credentials, tested and everything worked as expected. i tried to push this new POC workflow to Alteryx Gallery and got exactly same error your mentioned, although the workflow was saved to Gallery. BUT when i opened that workflow in server designer then giving same error.


Not sure what is the issue as both local and server designer and salesforce input tool are exactly same version. Requesting some help on this.


Thank you



8 - Asteroid

This error is because of the change in Alteryx Designer 2020.3 and later to upgrade from Python 3.6 to Python 3.8.


There are some local (your machine) and server changes that have to be made.

  1. Download latest version of Salesforce Input tool on both your machine and server.  It is still v4.1.0, but something like Version 12 which was updated in January or February 2021.!app/Salesforce-Input-Tool/59b84ccbeffc2a09d4057c43 
  2. Make registry change on your machine.
  3. Make registry change on server.
  4. Republish workflow to server.


The registry change is explained in this document: 


You can see my experience and the progression of troubleshooting in this Community post: 


It should now work.


Hope this helps!


8 - Asteroid

Hi Todd.


See my post as I experienced and got help from Alteryx Support to solve.


I hope you already fixed it as I see your post is from September 2020!



5 - Atom

Thank you for the documentation on the registry key change. It worked when I made the change on the server and published the workflow to gallery as described. Getting the key added on local machines will be a different animal.  I need to be able to describe what this registry change does, in practical terms for our security team. Does this expose the password for people to see?  What implications does this change have beyond making the connector work?  The documentation didn't have clear notes on that.

8 - Asteroid

Hi Aaron.

Under prior version of Salesforce Input tool, which was macro-based, my understanding is the credentials were passed "in the clear".


With the introduction of  the Python-based SF Input tool, this was changed from macro.  


My understanding is this encryption parameter allows for the exchange of the credentials, but you're right -- the documentation refers to "hide encryption" -- what does "hide encryption" mean?


I suggest that you raise a support ticket to get this answer.  You can find who answered my question by using the link to the Community Support ticket found in my response to your post.