community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

Upgraded servers to 2018.2.6 and Macros stopped working

Meteor

I upgraded our servers and in production, Macros stopped working.  They run OK on the desktop, and I can run a macro from the engine.  It's when I publish a macro from my desktop to the server where I get an invalid path error on all the macros.  

 

Any suggestions?

 

Thanks

Diana

Meteor

 I opened Alteryx on all of the servers and tried to publish a WF with a cleanse tool.  Primary node worked fine, workers threw the error.  The issue was resolved by manually uninstalling the software and deleting any leftover files and folders.  Once I did that I reinstalled the software and re-tested.  Worker nodes were now finding the path to the tools.  Fixed that issue, BUT all of the in-DB connections had to be set up again and some workflows "lost" their alias connections. So I had to fix those.  I worked with Alteryx support on this.