Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Successfull workflow run but output file not saved

12 - Quasar

I have a workflow that reads in a file from a file server folder filters it and saves the filtered file back to the same folder with a different filename.

On Alteryx designer this works perfectly. When I run the same workflow on Alteryx Server it displays the output file but does not save it to the file server folder.

Alteryx Server is not saying the workflow failed but the resulting file is not saved to the file server folder. It is displayed as below. If I schedule the workflow it runs and seems to indicate it has saved the file but the file is not appearing in the filer server folder.



If I schedule the workflow it runs and seems to indicate it has saved the file but the file is not appearing in the filer server folder.





Any ideas why this would be?

12 - Quasar



It's a bit of a punt, but I think it's writing it to a different folder on the server than you might expect.


I found this in the past that Alteryx recreates a directory structure when you upload a workflow and it saves it in a different place.


I can't recall where exactly, but maybe search under the Server directory?




12 - Quasar

thanks for the reply Tom.


I'm saving to a file server path not the Alteryx Server itself though so I don't think it is what you said.

12 - Quasar

Yes, sorry, was a bit of a long shot. I'm assuming you're using a full path, and not a indirect reference (e.g. ..\Filepath\Filename)?


Not an answer to your question, but are you outputting the log results on the server? I found it useful to put the workflow inside a runner tool - you need the Crew Macros (from ChaosReignsWithin website) on the server for that - and then parsing the results from the workflow into a table.


Oh, there's a thought - can you try the workflow outputting data to a database? If that works, you'd know for sure if it's simply a file/directory issue.

12 - Quasar

Thanks again Tom. I have other workflows outputting files to Sharepoint and they work fine.


I am not sure why outputting to this other file server fails on Alteryx Server but works on Alteryx Developer.


As I say the workflow on Alteryx Server is reading a file from the same folder I am trying to write the output file to.

12 - Quasar

Thanks for the response and sorry I can't help you! I'd need to simulate the environment and that would take way too much setup unfortunately.

Good luck and would love to hear what the problem was when you find it!

12 - Quasar

I downloaded the workflow from the server and it has lost the absolute addresses from the input and output tools.


I tried unchecking as below and this did not seem to change that.


Any ideas?



12 - Quasar

Ah, so it seems similar to what I had come across.


I think I had solved it by using relative paths locally and assuming that Alteryx would store it in it's own directory (as you've indicated). So mimic the drive structure and just refer to the relative locations (e.g. ..\Enhanced Fiscal\....


I had control over the server though, so not sure if that is something you can influence. We may need to reach out to Alteryx to understand the server operations here and why it changes the absolute paths of the files.

12 - Quasar

I have been doing some more investigation. If I save as the workflow to server it removes the file path from the input and output tools leaving just the filename. If I then paste the full path back into the input and output tools and save to the server again they stick.(not save as but save).


So to make the file paths stick I have to save them to the server twice, then they work.


That is not expected behaviour, we demonstrated it to one of our Alteryx support folks and I believe it is being raised as a bug.



8 - Asteroid

Hi ,


Have anyone found this issue getting resolved.