alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

Issue Using Adobe Analytics tool when uploading workflow to server

Highlighted
Meteoroid

We are having an issue where I have built a number of apps and workflows that use the Adobe anlaytics tool as part of the data source that presents a macro error when uploading the workflows to our Alteryx server.  the Adobe tool uses a number of embedded macros so it does not show in the "assets" window of the workflow upload screen and as a result cannot locate the relative folder "\AdobeAnlaytics\supporting|macros\ <macro_name>" and throws a validation error.  I have tried moving the macros to a network location and updated workflow xml and adobe tool xml configs that can be seen both by my local and the server but it still throws the same error.  Has anyone had a similar issue and find a way to resolve?  I am thinking that a copy of the tool also needs to be installed on the server but has anyone had experience as to how to do that too?  I have attached the specific error message.  Let me know if you need me to attache anything else or supply additional details.  thanks!

Highlighted
Alteryx Certified Partner

Hi @kwinstead,

 

Ideal solution would be to ask your Alteryx Server admin to install that macro on the server directly. That said, you can specify additional assets to include in the package when publishing to Gallery. In your user settings (Options > User Settings > Edit User Settings), in the Advance tab, check the "Display Asset Management in Properties Window" option and OK.

 

This will display a new option in the properties window that allows you to add additional assets to a tool in addition to showing you what assets it's already including.

 

Add whatever is missing and when you publish, it should pop up in the asset window when you publish for inclusion/exclusion.

image.png

 

Hope this helps!

 

Jimmy

Highlighted
Meteoroid

Thank you for your help!  This is very helpful and I appreciate explanation.  For installing a tool on our server, does it need to  be added to the server instance of designer or is there another way to add it  I want to make sure I provide accurate instructions to our administrator.  Thanks!

Alteryx Certified Partner

@kwinstead,

 

Install would be very similar, but they just need to make sure that they install it as an administrator so that it's available for all users. If they don't see the options shown below, tell them that they'll need to open designer as an admin (Right click > Run as Administrator) then File > Open Workflow > Browse and navigate to and open the .yxi file.

 

image.png

Highlighted
Meteoroid

This is great, thank you very much for your help!