Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
The Expert Exam is now live online! Read about the specifics and what it took to bring it to life in the blog by our very own Elizabeth Bonnell!
SOLVED

Fresh install of Alteryx Server 2020.2 won't start

Highlighted
Alteryx Certified Partner

Hi

Out old virtual server of Alteryx crashed, so I thought it would be easy to to a new fresh install.

 

So on a new VM, 4 CPU 32 GB RAM I made a fresh basic install of Alteryx Server 2020.2.2.27029
(Basically just next, next, next)

I had some issues with the license key, since it seems to still be assigned to the old machine (the new machine has the same name), so while waiting for this to be resolved, I installed as a trial

 

Verakso_0-1592307633496.png

 

But the server will not start, LastStartupError is just "Gallery Service failed to start in a timely fashion".

I have plowed though the community, and I have

  • Checked for anything else on port 80
    (To the best of my abilities I cannot see that there should be anyting else running on port 80)
  • Added the ServicePipeTimeout and set it to 180000

 

So I am out of clues what to do next.
I am just using built-in MongoDB and Authentication type, and have encountered this issue before

 

Any furter hints in troubleshooting this?

Br
\Verakso

 

Highlighted
Alteryx
Alteryx

Hi @Verakso I would really advise that you send an email to support@alteryx.com to log a ticket. They are experts in installations issues in particular installations when the service doesn't start.

Highlighted
8 - Asteroid

A few things come to mind:

 

- make sure FIPS is disabled on the VM

- make sure you're referencing localhost or the machine name as the gallery url. If you spammed next through the configuration settings, this shouldn't be an issue

- I've seen failed startups due to specific anti-virus software. Sometimes a second (or third) startup attempt will work properly, or you can whitelist Alteryx from the AV software (or temporarily disable it)

- If you're trying to restore from another VM, try deleting and recreating your mongod.lock file in the Persistence folder

Highlighted
Alteryx Certified Partner

Hi @raychase 

 

I have accepted you answer as the "solution" since you pointed me in a direction that solved the issue.

 

The VM settings was the same as the where before, so that was not the issue, but actually the URL of the server.

 

Because I actually didn't use localhost the the old servers FQDN, which should have worked.
When I changed it to localhost the server did start. it made me wonder why, since the FQDN is perfectly valid.

 

But here is the tricky part. The server has an internal address, and an external address, that is routed through a proxy.

So on the inside the FQDN is resolved by the internal DNS that points to the proxy on the inside. on the outside the public DNS points to the public IP of the proxy, and normally this works like a charm.

Except for this time, there was an issue with the proxy (nginX) but once that was re-started, I did manage to get the Alteryx Server up and running.

 

Took me a while though figuring this out, since it worked before, so I would have liked for a better error than "Gallery Service failed to start in a timely fashion"

 

So thanks for the reply.

Highlighted
8 - Asteroid

@Verakso that's great news that my ideas at least helped you down a particular path. I agree that the verbiage in the error logs can sometimes lack helpful detail. I will keep your proxy issue in mind in case we ever run into similar issues. Thanks for sharing your results.