Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Error 400 on Alteryx Server when using gsheet output tool

8 - Asteroid

Hi all, 


I have a workflow which outputs to a google sheet and it runs successfully in Designer but errors with the following message in server: 




When setting up the tool I tried both options - clicking straight on 'Connect' and the OAuth option with a Client ID and Client secret I obtained through the Google APIs page. I followed the steps described here for the latter. I had no luck with both 😞


I am using the 'Overwrite Sheet Drop' output option in the gsheet tool but have tried others and it still didn't work. I have tried in Alteryx versions 2020.1.5 and 2020.3.5 and gsheet connector version 2.1.0. 


Does anyone know of a potential solution? Many thanks in advance!!! 


P.S. Interestingly, I also have 3 google input sheets in my workflow and they run without a problem on the server.

8 - Asteroid

Update: the issue was resolved by ensuring the same version of the google connector tools were installed on the server and on my Alteryx Designer