Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
The Expert Exam is now live online! Read about the specifics and what it took to bring it to life in the blog by our very own Elizabeth Bonnell!

CREW MACROS-external program "SupportingExes\AlteryxRunner.exe" returned error 1073741502

Highlighted
Alteryx Partner

 The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1073741502

 

All the crew macros jobs are failing in schedule. The workflows are working if run manually instead of schedule.

 

Things checked:

  • Reinstalled Crew macros in D drive
  • checked the path of macros in C:\ProgramData\Alteryx\DataProducts\AddOnData\Macros: pointing to the one installed[Settings]
    DefaultFolder=CReW Macros
    MinimumAlteryxVersion=10.0
    Path=D:\AlteryxMacros\Macros\Macros
  • Added the path in environmental variables

Restart of the server helped to resolve the issue temporarily.

 

The same issue popped up again during the weekend. 

  • Checked workflow dependencies and tested, its unable to find the directory.

 

All the jobs were running fine previously, but the issue started from 2 weeks.

There were user-defined macros created recently but checked it is not affecting this as the restart of the server ran all jobs normally.

 

Versions:

Latest Crew macros

Alteryx Version: 2018.2

64 BIT Windows Server 2012 r2

 

If someone has come across this issue previously or know any solution to this issue please let me know. 

 

Thanks in advance.

 

 

Highlighted
10 - Fireball

Hi, have you checked to see if you have valid credentials in Alteryx System Settings under "Run As"? This is the place that will house credentials that will give scheduled and Gallery loaded workflows access to directories in your environment. If you don't have credentials there, Alteryx uses the system default which generally does not have access to much in the environment.

Highlighted
Alteryx Partner

Hi Paul, Thanks for the reply.

 

We are using a service account ID  for "Run As" in the settings and it has access to all directories in the server.

 

Highlighted
7 - Meteor

Hello

 

Did this get resolved?  I am facing a similar issue this morning

 

Thanks 

 

Regards

Richard

Highlighted
Alteryx
Alteryx

@Rich_Stebles 

Not that I'm aware of, but you are not the only person who's recently observed it.  I'll keep this space posted with whatever I discover.

Lisa LePome
Senior Customer Support Engineer -- Knowledge Management Coach
Alteryx, Inc.
Highlighted
Alteryx Partner
Restart of the server fixed the issue. It came in for some time, but now it's stable.
Highlighted
10 - Fireball

Never underestimate the solving power of turning it off and back on again!

Highlighted
8 - Asteroid

@Tirumal @MarqueeCrew @LisaL 

 

I am facing the same issue in gallery server. I am using CREW LIST RUNNER to pickup my workflow and run it from shared drive. 

 

  • Tool #4: Tool #3: Iteration #1: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1073741502
  • Tool #4: Tool #3: The output connection "Logs" was not valid

I cannot request my admin team to restart the clustered server, Please let me know if you know any other solution?

 

Thanks