Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Alteryx Gallery Timeout on Download, Runs to Success in Designer

slcorey
6 - Meteoroid

I have an odd issue and was wondering if someone is able to point me to where I can look in logs for more details?

 

The workflow connects to a website and downloads an xlsm file.  The connection goes through just fine when I run the workflow from Designer on the server.  I see the outgoing connection on our proxy firewall, connection success, and the file downloads.  This tells me the external connectivity is functional from the server. (Screencap Attach #1)

 

When I run the same workflow through Alteryx Gallery, I get a timeout on the download step (Screencap Attach #2).  I have checked the setup of server and see I have not set a timeout in Gallery through the Alteryx configuration.  Is there somewhere else I should be looking?  I don't see any traffic attempts on the proxy firewall when run through Gallery.  Is there an explanation for the behavioral difference?

 

Thank you,

Stephen

2 REPLIES 2
dana_mcdonough
Alteryx
Alteryx

Hi @slcorey - The storage location for Gallery log files is set to C:\ProgramData\Alteryx\Gallery\Logs by default. Customize the location, if necessary, on the System Settings > Gallery > General page.

 

Here is a resource for more information on Server logs: https://help.alteryx.com/20212/server/configure-and-use-server-logs

slcorey
6 - Meteoroid

Thank you Dana!  I reviewed the logfile and did find an entry that corresponds to the timeout.  It looks like it is able to connect, but throughput is very slow.  It seems to only read 3 records before timing out and write none to the file:

 

2022-06-24 13:43:04.768130,DEBUG,45,AlteryxServerHost,EngineQueue,TranslateJob,3e3e79bc35ef43e59d4fd14c07ad414f,6202c548417d94c693748a05,10.95.10.17,TEST-ALTERYX,"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.0.0 Safari/537.36",GET,/gallery/api/jobs/62b5bf4e625d0000fc004be9/,,-1,"Response|6202c548417d94c693748a05|TranslateJob||jobId=62b5bf4e625d0000fc004be9, disposition=Error, messages=[toolId=-1, status=1, text=Running at a Low Priority.],[toolId=24, status=1, text=1 record was output],[toolId=25, status=1, text=Records transferred: 1; active connections: 1; average records per minute: 3],[toolId=27, status=1, text=0 records were True and 0 were False],[toolId=16, status=8, text=D:\Batch\*****\MM-DD-Master-weblist.xlsm|0 records were read from ""D:\Batch\****\MM-DD-Master-weblist.xlsm"" (`Web List$`) (limit reached)]

 

Should I open a case for this or is there a configuration I should review that might be holding the workflow back?

 

Thanks again!