Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Check out our powerful new search update! You can read more here. Please let us know if you have any feedback by creating a topic here.
SOLVED

Summarize Tool system error message

Highlighted

I am using an admin version of 2018.2.5.48994 and running non-elevated. I am now receiving the following error on any summarize tool: Error: Summarize (1): The plugin "C:\Program Files\Alteryx\bin\plugins\AlteryxSpatialPluginsEngine.dll" could not be loaded: The specified module could not be found. (126)

Capture.PNG

 

Has anyone else come across this/have any ideas on how to fix it/diagnose what's going on? The strange thing is an uninstall/reinstall seemed to clear the issue on Friday, but then it popped up again this morning!

 

I have submitted it to support, but I figured I would see if anybody else has come across this as well.

Highlighted
Alteryx
Alteryx

I've had that message pop up when I accidentally had two versions of Alteryx installed. Check to see if an update didn't remove the old version.

Regards,
Stephen Ruhl
Customer Support Engineer

Highlighted

@StephenR Thanks! I checked and only have 1 version installed. It looks like something is goofed up with the data install. When I disconnected the data by deleting all the INI files, it returns back to normal.

Highlighted

I get the same error message. Weird, since i'm looking at the "missing" dll. It's happened a couple of times before. Rebooting, or running as administrator clears the error. Annoying nonetheless.

 

Using admin version 2018.3.4.51585

Highlighted
Asteroid

@patrick_digan In my case, I have noticed that opening the designer in admin mode isn't really helping the cause. I have started noticing this only after installing data packages recently. Is there a solution for this? Please advise.

 

My version is 2018.4.

Highlighted
Meteoroid
We are having a similar issue. Is there any update on how to resolve this?

Thanks.
Highlighted
Alteryx Partner

I also am now getting this error after upgrading to 2019.3... I checked for two installs, and didn't see a second one. So I uninstalled and then reinstalled 2019.3, but I'm still receiving the error. Any thoughts on another solution?

 

clipboard_image_0.png

Highlighted

@kapratt @TimN @timewaste @TowerOfPower Has anybody gotten to the bottom of this? I can replicate the issue by using an input tool, connecting to an any oracle database, and then clicking refresh on the input tool. This seems to be the only time the issue pops up. Once it pops up, I just have to close Alteryx to clear it. Nobody else on my team seems to be having the issue. And I can connect to various other databases without the error popping up. I'm working with support, but they're still baffled at why my machine is throwing this error. I am one the few people who uses some of the data packages, but uninstalling them hasn't cleared the error either.

Highlighted
Alteryx Partner

@patrick_digan I was finally able to fix this, simply by moving the datastream leading up to the Summarize tool out of the In-DB workflow completely via an output to an Alteryx database and an input to the same file in the next workflow.

 

I was able to recreate the problem by having In-DB tools in the same workflow as a Summarize, so I believe that in at least my case this was the cause.

Highlighted

@TimN @timewaste @TowerOfPower 

 

Alteryx Support (@ntobon) just provided a simple fix for my situation!

 

"We were able to replicate on one machine; it has something to do with how OCI is installed, but we couldn't figure out exactly what.

What worked on that machine was to add the bin directory to the PATH variable: C:\Program Files\Alteryx\bin

Could you please add the non-admin bin directory to your PATH and test it again?  Please let us know if adding the non-admin bin path resolves the issue."

 

So if you're running the Admin version of alteryx, you have to add: C:\Program Files\Alteryx\bin

and for the non-admin version:%LocalAppdata%\alteryx\bin.

 

On windows7/10 you should be able to go to start >>> type "Edit System" >>> select Edit the system environment variables >>> then edit the user's or system's PATH variable to add the appropriate folder. 

 

I no longer receive the error with the summarize tool now!

 

 

Labels