community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE
SOLVED

Python Tool - Issues with Output

Atom

Hi,

 

I'm using Alteryx 2018.4 x64 and am trying to use the Python Tool.

Just going through a very basic test I get the following error along with no output from the tool:

 

PythonToolError2.png

 

PythonToolError.png

 

I have tried rerunning the notebook, re-running the alteryx module, checking if the results are coming out of any of the other outputs but no luck.

Is anyone else having success with this and may be able to point me in the right direction?

 

Thank you.

Alteryx
Alteryx

Typically, this error is solved by re-running the Alteryx workflow. It looks like you have tried that and it hasn't worked. Can you paste a screenshot after running your workflow?

 

I recreated your example in the two screenshots. The Before Execution screenshot is directly after opening the yxmd file, and I get the "no valid metadata" error. After running the workflow, the error goes away, and I can see the output data in the "After Execution" screenshot. Note that this warning comes back when you click off of the Python tool. The data is passed to Jupyter via a cache, allowing you to interactively modify the data in your notebook. You will need to re-run the workflow to send the updated data to your downstream tools.

Atom

I have attached the screenshots of my attempts at restarting the workflow and rerunning.

 

The order is:

Before > After > After+ClickingOnBrowse > After+ClickingBackOnPythonTool > After+Restarting....

 

Could I see what you have in the rest of your jupyter notebook just to make sure it doesn't differ significantly from mine.

Alteryx
Alteryx

I made a few changes to my Notebook and designer layout to reflect what you have. I've attached the file with the complete notebook. I also have a complete log. Are you seeing in yours that the data was successfully written to anchor #1?

 

If you try to create a new workflow with the default horizontal layout and white background, do you get the same error? What if you Browse for a csv instead of text input?

 

Atom

The following fixed the issue:

 

Options > User Settings > Restore Defaults.

 

Having done that, I changed my settings back to what I thought they were and every still works fine now.

 

It must have been some default (or modified) setting that I brought over from the old alteryx version I was using (10.x, 11.x) prior to upgrading to 2018.4.

 

Thank you for your help.

Labels