Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

results window not displaying data anymore

8 - Asteroid

i am not sure what happened but i used to be able to click on the green arrow to preview my results.  now this has stopped working. every time i  click the green arrow leaving the module to preview results it says no data available press control R to run the workflow. i am using 10.6. This must be an option or setting i can change. PLEASE HELP!!!!!!!

ACE Emeritus
ACE Emeritus

Hi @MarcyB this issue is usually a memory problem. The amount of data shown in the anchor is limited as specified in your user settings. Try nudging this up slightly and see if this allows you to preview your data.


The setting can be found by going to options > User Settings > Edit User Settings > Advanced > Tool Result Settings and then hit 'overide'.



5 - Atom

I had the same issue and @BenMoss this solved the problem.  My yxdb was bigger than this limit so no data preview would show up in the workflow on any tools, except browse tools.

6 - Meteoroid

Its also because of the memory space usage , where you cannot see the data even the run was succesful.


In workflow configuration go to Runtime --> use specific Amount, increase the size then save it, close and test again.


or another option.. 

go to  options--> usersettings --> edit user settings --> override system settings, change the buffer size.


hope it helps

7 - Meteor

I just had the same issue.  The results window was not displaying even though I have the View/Results checked.  I was able to resolve it by going to Options/User Settings and clicking on Restore Defaults.  This corrected the issue.     

5 - Atom

I've had this issue for over a year and everything else I found and tried never worked.  Restoring defaults worked for me.  Thanks kcvictor for sharing!

7 - Meteor

I have tried increasing memory and restoring defaults, but when running analytic apps the data preview stopped working.  I am using 2019.3 and prior to today the analytic apps were working fine.  My regular workflows still display data as I would expect, and so it is very puzzling to me why the analytic apps do not.


Nevermind the green anchors, even when clicking the Browse tool in the canvas I see no results.   I am not receiving any error messages, and as such I am dead in the water as it is very difficult to use this tool sans the data preview.


I hope someone at Alteryx can advise and assist as this is crippling. 

6 - Meteoroid

I was having this issue as well. We found another topic that fixed me.


Try the solution that JPoz subbed.

8 - Asteroid


Disable all browse tools was preventing data from showing in ALL of my tool anchors!


5 - Atom

Same! Thanks for sharing! 🙂 I would have thought that would have just disabled the browse tools not all results from populating in the results pane.

5 - Atom

Hi All,

This happened to me too, but that was because I had checked the "Disable All Browse Tools" under the Runtime options.

It turns out it will block the results/data screen too.


Click on an empty part of the canvas > Click Runtime > uncheck Disable All Browse Tools.