Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Input tool not reading '.xlsx' file correctly

7 - Meteor

Hi all,

I've encountered a strange problem.


The input tool is mis-aligning the data from an xlsx file:



The data show in row 57 above should be included in a column in row 56.
The column is a comment column and the character length of that specific column was 150 characters. 

The above data is copied from the input tool results. This is how the input tool is reading the xslx file.

The actual xlsx file is perfectly alighned. There are only numbers in Column A.

When I run the workflow, the output is inaccurate because the input tool is putting the comment from row 56 spread out in row 57.


What are my options to get Alteryx to read this xlsx file correctly?


Input Tool Configuration below:



I have tried using the Excel Legacy option but Alteryx input tool reads it the same as a non-legacy xlsx file.

I have also tried xlsm and -b options. 




7 - Meteor

There were a few columns with many characters and so I stretched their size limit to 10000+ in the Select tool after the input tool and the misalignment issue isn't there any longer.
Also, initially I was checking the results window but I've re-learnt that Alteryx restricts that window to 256 characters. Little finicky things to look out for.