We have extended our Early Bird Tickets for Inspire 2023! Discounted pricing goes until February 24th. Save your spot!

Dev Space

Customize and extend the power of Alteryx with SDKs, APIs, custom tools, and more.

Issue with AYX Python SDK

jguszr
5 - Atom


I'm Trying to "format"some python code as a Alteryx tools and Im facing some issues when i try to run the ux. Let me detail my enviroment and the error Im getting in order to better explain my problem : 

Tools & Versions :

1 - Alteryx Designer : 2022.3

2 - Python 3.8.5

3 - Node 19.3.0

4 - Alteryx CLI Version: 1.0.4

 

All tools were installed properly without warnings or erros

 

I was able to follow the tutorial at https://help.alteryx.com/developer-help/platform-sdk-quickstart-guide until the UI SDK step.

When I try to run the web interface using the line npm rum star (in the proper folder) I get the following error stack : 

 

 

 

(base) c:\projetos\testAlteryxPlataformSDK\ui\secTEster\src>npm run start

> dev-harness@1.0.0 start
> webpack-dev-server --open --config webpack.dev.js

(node:9036) [DEP0111] DeprecationWarning: Access to process.binding('http_parser') is deprecated.
(Use `node --trace-deprecation ...` to show where the warning was created)
i 「wds」: Project is running at http://localhost:8080/
i 「wds」: webpack output is served from /
i 「wds」: Content not from webpack is served from c:\projetos\testAlteryxPlataformSDK\ui\secTEster
Error: error:0308010C:digital envelope routines::unsupported
at new Hash (node:internal/crypto/hash:71:19)
at Object.createHash (node:crypto:140:10)
at module.exports (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\util\createHash.js:135:53)
at NormalModule._initBuildHash (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\NormalModule.js:417:16)
at handleParseError (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\NormalModule.js:471:10)
at c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\NormalModule.js:503:5
at c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\NormalModule.js:358:12
at c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\loader-runner\lib\LoaderRunner.js:373:3
at iterateNormalLoaders (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\loader-runner\lib\LoaderRunner.js:214:10)
at iterateNormalLoaders (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\loader-runner\lib\LoaderRunner.js:221:10)
Error: error:0308010C:digital envelope routines::unsupported
at new Hash (node:internal/crypto/hash:71:19)
at Object.createHash (node:crypto:140:10)
at module.exports (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\util\createHash.js:135:53)
at NormalModule._initBuildHash (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\NormalModule.js:417:16)
at handleParseError (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\NormalModule.js:471:10)
at c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\NormalModule.js:503:5
at c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\NormalModule.js:358:12
at c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\loader-runner\lib\LoaderRunner.js:373:3
at iterateNormalLoaders (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\loader-runner\lib\LoaderRunner.js:214:10)
at iterateNormalLoaders (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\loader-runner\lib\LoaderRunner.js:221:10)
node:internal/crypto/hash:71
this[kHandle] = new _Hash(algorithm, xofLen);
^

Error: error:0308010C:digital envelope routines::unsupported
at new Hash (node:internal/crypto/hash:71:19)
at Object.createHash (node:crypto:140:10)
at module.exports (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\util\createHash.js:135:53)
at NormalModule._initBuildHash (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\NormalModule.js:417:16)
at handleParseError (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\NormalModule.js:471:10)
at c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\NormalModule.js:503:5
at c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\webpack\lib\NormalModule.js:358:12
at c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\loader-runner\lib\LoaderRunner.js:373:3
at iterateNormalLoaders (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\loader-runner\lib\LoaderRunner.js:214:10)
at Array.<anonymous> (c:\projetos\testAlteryxPlataformSDK\ui\secTEster\node_modules\loader-runner\lib\LoaderRunner.js:205:4) {
opensslErrorStack: [ 'error:03000086:digital envelope routines::initialization error' ],
library: 'digital envelope routines',
reason: 'unsupported',
code: 'ERR_OSSL_EVP_UNSUPPORTED'
}

I was unable to find a solution on google/stackoverflow, but all suggestion regarding the [DEP0111] error messages seems to be a far cry from what I actually need to fix the issue

 

Any sugestion ? 

 

Regards !

0 REPLIES 0