Dev Space

Customize & extend the power of Alteryx. SDKs, APIs, custom tools, and more!

Error getting Common AppData Path

alanboc
5 - Atom

hi all

 

I'm getting this error when alteryx tries to execute the "dynamic input".

this message is very general and I couldn't realize whats going on.

 

basically there is a web application and there is a IIS user that starts the ateryx flow.

I checked all the folders related with alteryx and put this user with all permissions.

but no effect.

 

Does anyone could help me to find how to fix this ?

Regards 

Alan

7 REPLIES 7
RishiK
Alteryx
Alteryx

Hi there

 

Are you running the workflow via the Alteryx Server or in Alteryx Designer itself?

alanboc
5 - Atom

hi rishik

 

via Alteryx Server.

through Alteryx Designer, there is no problems when I run the flux.

 

Thank you

 

RishiK
Alteryx
Alteryx

Hi there

 

So this looks like a permission issue.  It will be fine via Alteryx Designer because the user you are running the workflow through in Designer has access to the location you're accessing through the Dynamic tool.

 

Can you check if the user account you are running via on Alteryx Server, has access to that path / location?

alanboc
5 - Atom

hi I checked all the folders related with alteryx and put the user from iis server with all permissions.

but unfortunately, same error.

 

 

matt2
7 - Meteor

I got it to work by installing v.3.1 of the tool.  In my Designer (2019.2), I have to right-click in the Toolbar (toward the top of the screen, under the "Collections" buttons) and choose "show depreciated tools" so that the old version shows up, but then I can add the working depreciated tool to my workflow.

 

Please "star" the product idea I added to the Server Community:  

https://community.alteryx.com/t5/Alteryx-Server-Ideas/Salesforce-Connector-v-4-1-doesn-t-work-on-Ser...

 

Someone who knows told me that getting a lot of stars on a product idea is THE way to tell Alteryx how important something is.

gade_joseph_r
9 - Comet
Biswajyoti
5 - Atom

 

Hi all,

 

expecting a quick help. If the issue is solved by the requester kindly guide .

while running a job local with DB connection the job is running fine. But when I tried to run it on the server it is throwing an error at the input nodes that: Error Getting Common AppData Path. for flat files as input we are not getting this error, while running in the server but for DB connection in input while running on the server I am getting the error. I checked the log files and instance name of DB everything is correct. Can anyone suggest something on this?

I checked this on community but did not get any solid answer. My server is having a service account and it has all the permission for the folders. All the jobs are previously running fine but suddenly from today, it is throwing me this error. I find nothing in the logs.

 

Thanks!