community
cancel
Showing results for 
Search instead for 
Did you mean: 

Dev Space

Customize & extend the power of Alteryx. SDKs, APIs, custom tools, and more!

Alteryx Server not respecting VirtualEnv when running through Gallery

Asteroid

Hey Alteryx devs,

 

I just came across a weird behavior involving a Python SDK tool and Alteryx server:

 

For my tool I'm using gensim==3.8.0 and numpy==1.16.4. Everything works well in my local Alteryx Designer, the Alteryx Designer on the Server and when running the workflow through AlteryxEngineCmd.exe on the server. So, I expected the workflow containing my Python tool to work well when uploading to the Alteryx Server.

Alas, it did not: I ran into errors indicating, that a different numpy version was used. I tried to debug the whole virtual environment of my tool, but to no avail.

 

It was only, when I reinstalled gensim after uninstalling numpy and reinstalling the default numpy==1.14.2 version that ships with Alteryx' Miniconda3. Luckily, in my case there seems to be no problem using an old version of numpy. But the behavior is completely unexpected.

 

It seems like the Alteryx server does not respect the virtual environment and the installed package versions when running a workflow through the gallery. Instead, it seems the python installation uses gensim from my tool but numpy from the default Miniconda environment.

 

In my view, this is a bug, because it makes developing tools with a consistent environment neigh impossible. Hopefully, this is addressed in a future version.

 

Best

Christopher

 

Alteryx
Alteryx

Hi @chrisha - thank you for reporting this unexpected behavior. I will start looking into it and may reach out via email to get more details. Thanks!