Oh no! The Community appears to be haunted! Help us find all the spooky specters here.
We are currently experiencing an issue with Email verification at this time and working towards a solution. Should you encounter this issue, please click on the "Send Verification Button" a second time and the request should go through. If the issue still persists for you, please email support@alteryx.com for assistance.

Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

Writing to/reading from Temp Files Chained App

kylemhabe
8 - Asteroid

Hello,

 

I have developed a chained app that writes to temp .yxdb files in the first workflow. The second workflow reads from these temp files and does further data manipulation. I am publishing this app to my firm's server so that those without Alteryx Designer can run the application. This app works on my machine but I have been having trouble getting it to work on my firm's server. Essentially, the first workflow (writing to the temp files) runs fine;however, when I run the second workflow (reading from the temp files), i receive the following error messages:

 

tempfile chained app.png

I saw a few posts with a similar issue but could not find a clear solution.

 

Here are how my how my input/output tools are configured. 

 

output.png

 

output.png

I also tried to write/read to regular .yxdb files with relative paths;however, I was receiving an error after the first step that I do not have access to the directory when trying to write to the .yxdb files.

 

I guess that I may need to get my firm's Alteryx server team involved but I figured I'd ask here.

 

As well, this app needs to be run in two steps because it is possible that the user may need to update an input file after the first workflow is run.

 

Best,

Kyle

 

 

5 REPLIES 5
blyons
10 - Fireball

Did you ever resolve this? If so, do you mind sharing the solution?

kylemhabe
8 - Asteroid

Unfortunately I was never able to resolve and I haven't had a chance to revisit in a while.

AkimasaKajitani
15 - Aurora

Hi @kylemhabe @blyons 

 

I understand the reason why the workflow is work at Local Machin, but is not work at Server.

I think it will work if you set the file path to only file name.

 

%temp%..\County Info.yxdb  =>  County Info.yxdb

 

That file path(%temp%..\County Info.yxdb) is outside the area that the Server prepares for workflow execution, so it cannot access the file path for the security reasons.

 

JagdeeshN
11 - Bolide

@kylemhabe @blyons 

 

I think the trick here is relative paths and folder structures.

 

Please attached a zip which contains the following folders:-

 

1. workflows:- Consists of the two applications.

 

 First Application.yxwz is the workflow that reads data and writes into yxdb. Second Application.yxmz is meant to do the transformations on the data written earlier. It then stores this transformed output into new yxdb for demonstration purposes.

 

2. data files:- Consists of all data files.

This includes the yxdb's created by First Application.yxwz and the Second Application.yxmz

 

I tested this on the server and it seems to work.

 

Please do let me know if this works.

 

Best,

Jagdeesh Narayanan

blyons
10 - Fireball

The relative paths are important and can be tricky. Options->Advanced Options->Workflow Dependencies definitely help with that.

 

However, the main issue for us turned out to be permissions on the server. The account configured to run the worker needed to be granted explicit full-control permission to the Service\Staging folder. This was very odd because the account was already in the local administrators group, and the "effective permissions" already showed as full control. However granting that specifically to the account solved the problem.