Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
Don't forget to submit your entry for the Excellence Awards by October 30! | Need more information about the program? Check out the blog here
SOLVED

Workflows intermittently failing: error code 3

Highlighted
8 - Asteroid

I have a workflow that runs daily and I'm having an issue were the job will sometimes fail and if I run it manually from the server it could fail 1 or 2 more times and then successfully run.

BonusCup_0-1596213021300.png 

 

BonusCup_0-1596213538345.png

 

Has anyone run into this issue before and how did you resolve?

 

TIA

 

 

Highlighted
Alteryx
Alteryx

@BonusCup,

 

To be able to properly troubleshoot your issue it will be best if you work with support directly.

Open a case by sending an email to support@alteryx.,com

On the email include the following:

• Screenshot of Alteryx Server version - (Help - About)
Copy of the batch file you are trying to run with the workflow
• Copy of the workflow
• RuntimeSettings.xml File - %ProgramData%\Alteryx
• Service logs - %ProgramData%\Alteryx\Service  (logs since last couple of days)
• Gallery logs - %ProgramData%\Alteryx\Gallery\Logs   (logs since last couple of days)
• System Info - Start menu > search/type msinfo32.exe> File > Save as .nfo file.
• Windows Event Viewer Logs - (Windows Start menu > search for “event” and choose Event Viewer > Expand Windows Logs > right-click on ‘Application’ > select   ‘Save All Events As…’ > save as *.evtx file.  Also right-click on ‘System’ > select ‘Save All Events As…’ > save as *.evtx file)
• Engine log - for the engine logs location look into the Alteryx System Settings > Engine > Logging directory.  Keep in mind that each workflow run will generate one separate engine log.  You will need to find the log for the Gallery run failure.  Easiest way would be to reproduce the issue and get the log right away.
 

 

Highlighted
9 - Comet

We have experiences like this in our multi-worker gallery when one of the workers can't access a needed asset. If you have multiple workers, try remote desktopping to each with the service account credentials and running your workflow from the worker's designer to recreate the problem.

Highlighted
8 - Asteroid

@hroderick-thr 

 

Thank you, this was the issue.  Our admins gave me access to select different workers to run manually from the Gallery and I found which worker my workflows were failing on.

 

Thanks again!

Highlighted
9 - Comet

Great news!  If you or the admin can run it on the failing worker using desktop it will give more insight into the error. I find that to be quicker than pouring over the logs.