Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Workflow truncates table on schedule, runs fine manually (server)


Hey Everyone, 


I seem to have a strange situation I can't figure out. I have a somewhat complex workflow that grabs data from multiple locations, does a lot of transformations, and outputs the data into 2 tsql tables (using delete and append). 


The issue is that when I schedule this job on the server, it runs but truncates the tables, so no data. When I troubleshoot this by running the EXACT same workflow manually (also on the server), it runs totally fine and loads the tables as expected. Note that I've tried multiple schedule times over the course of several days - all end in the same result (truncation). 


Any ideas as to why this is? The scheduled jobs don't look to be returning an error so it's difficult to troubleshoot. 


Thanks in advance 


Without seeing this in action, let's troubleshoot together.


So perhaps what is happening is that everything is actually working fine but when it's scheduled, no records are actually reaching your output? 


Look through the run logs from your scheduling interface in Alteryx Designer. Perhaps you are truncating and nothing is making it to the end.


Report back.


I think it's actually a network issue because depending on the time I schedule the job, it runs. So I'm adjusting the schedule for now, and we'll see how that goes. 


okay please do keep us posted!