community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Unknown Error validating the workflow when saving app on company gallery

Highlighted
Meteoroid

Hello all, 

 

I upload a alteryx app on our company Alteryx gallery, and call this app from an external website via REST API. It worked well but is down now.

 

There is an unknown error when I saving the app to our company gallery as the following image:

 

Alteryx saving error.PNG

 

Once I try to save any app to our company alteryx gallery, even some official sample apps, it can save but always gets an error when saving the workflow :" There was an unknown error validating your workflow. This may cause issue when running in gallery".  So I cannot run the app on the server. But the same app can save and run on Alteryx public gallery. 

 

I cannot find any issue and any clues from this, dose anyone have experience and knowledge on this issue? That's very important to us because it is a business application and need to be fixed as soon as possible

 

Thank you very much.

Are you able to Remote Desktop into the server?  If so, perhaps you can (a) attempt to run the workflow on the server and if successful, then (b) attempt to publish to Gallery from there also.

 

Also, do you have any non-Alteryx macros in the workflow?  If so, check that they're on Server.  Another thing to check could be any aliases.

 

Good luck!

 

Ciao,

David

 

 

Meteoroid

I get this same error. Is there any progress in solving the problem?

 

When I try to upload an app to the server, from the server itself (via localhost/gallery) it works just fine and can be ran from anywhere. But when I try to upload from a different laptop to the gallery it fails in the same way. If you try to run the app that failed to upload you get a "file in C:/Alteryx.../XprocessCache/etc does not exist" error. I verified that the file referenced in the error indeed does not exist on the server. Is it possible this is a network/security problem?

 

 

Alteryx Partner

Any update on this?