community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
Community v19.6

Looks aren't everything... But the latest Community refresh looks darn good!

Learn More
SOLVED

Unable to output CSV to Sharepoint

Highlighted

I've been working on a use case with one of our business users and can't seem to find cause/solution to this error.

 

The workflow is solid.  It builds a data set that gets divided into separate CSV files, by date, when being saved.

The problem is saving them though.  He needs them saved to a Sharepoint document library.

Output is set to \\ourcompany.sharepoint.com\thisdepartment\thatlibrary\Filename{%date for group of output%}.csv

When run on a desktop - no problem.

When run in desktop scheduler - again, no problem.

But, when run from the server's scheduler: "Cannot access the folder  \\ourcompany.sharepoint.com\thisdepartment\thatlibrary\."

Thought it was a permissions issue with the server running under its own service account so we added the server's account to 'full control' level of permissions for this library.  That didn't make a different.

We tried a number of other things, like sending it through DavWWWRoot, but that didn't help either.

At our organization, even if it's our server we cannot access it.  We have to send a request through IT.  So, for the most part we don't have much visibility to the Alteryx settings.

Our one attempt thus far to resolve this ended by IT advising that they prefer we not output directly to the Sharepoint and instead use a DFS which is mapped to Sharepoint.  But, they couldn't actually advise us on how to do this...

 

1. What Alteryx server setting should we be looking at?

2. Does anyone have a creative workaround?

3. I'm not experienced with Sharepoint and couldn't find any postings online elsewhere than matched up with IT's recommendation.  Does anyone have experience mapping a DFS to Sharepoint?

 

Alteryx Certified Partner
Alteryx Certified Partner

I've experienced a similar issue but it did not involve SharePoint. I am going to share it in case it helps but I am not 100% sure it will be a solution.

 

For us, the fix was in the server Run As account. Do you have the server setup to use a Run As account? If so, try removing that and setting up the actual AlteryxService to run as the account you wish: https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/sys_srv_logon_user.m...

Thanks.

That is sort of what I was afraid of hearing.

We can't make that modification due to IT policy.

We have an account set up to Run As (the service account IT gave us specifically for the server).  But, IT ultimately controls the permissions on that account.

Our IT security is top notch, which is usually good but can have its disadvantages as well.  This would be one of those.

 

 

 

Meteoroid

I'm getting the same error as the original poster, but its not due to the reason mentioned in the solution. 

 

It seems as though alteryx is doing a permission check before it writes, its good, but seems to be incompatible with sharepoint. It only seems to be doing this when run from my company's gallery and not when run directly on the desktop. Example...

 

This is what is configured in the output tool. This works when run on the desktop. 
\\server.net@SSL\DavWWWRoot\sites\spz342t\DropZone\File.csv

 

The error I'm getting from alteryx is that it can not access this path. See the \. tacked on the end.  

\\server.net@SSL\DavWWWRoot\sites\spz342t\DropZone\.

 

If you try to get to these locations using windows explore the one with \. fails as well. Whereas if I just go to \\server.net@SSL\DavWWWRoot\sites\spz342t\DropZone it works fine. 

 

It seems to center around how alteryx does the permissions check and this seems to be different if run in gallery vs on the desktop. 

Any help would be appreciated. 

@bobruddyhave your Sharepoint admin check permissions.  It sounds like the Alteryx server's service account isn't allow to access.

Meteoroid

As I mentioned above this is not a permissions issue. I've verified that. 

 

This has to-do with alteryx checking if it can write in a different fashion on the desktop execution vs the gallery execution. 

Alteryx
Alteryx

@bobruddy As @patrick_mcauliffe pointed out this error is indeed a permissions related issue. Depending on what component of the server is attempting to access the file this could be an issue with the Run As user defined in System Settings not having access to the file path, or if the Gallery process is attempting access the service account associated with the AlteryxService not having access. Even if these accounts have access to the resource you will likely still encounter permissions errors in Scheduler and Gallery when accessing these resources. The root of the problem is in how SharePoint handles the permissions checks, and that it incorrectly re-prompts for credentials for access requests coming from session 0. There have been a number of posts on community regarding these permissions issues and it is because of these permissions issues that reading and writing files to SharePoint directly via Document Libraries, WebDAV paths, and UNC paths isn't currently a supported functionality. At this time we only support accessing SharePoint via the including SharePoint List connectors and these only allow access to SharePoint lists at this time. 

 

Please feel free to review the following links for more information on this issue and why it isn't supported:

https://community.alteryx.com/t5/Alteryx-Server-Discussions/Gallery-Scheduled-Workflow-Output-File-t...

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/SharePoint-2013-File-not-found-issue/t...

https://community.alteryx.com/t5/Alteryx-Server-Discussions/Scheduler-amp-Sharepoint/m-p/86274

 

 

If you would like to see supported functionality for accessing SharePoint document libraries you can contribute to the following product ideas post:

https://community.alteryx.com/t5/Alteryx-Designer-Ideas/officially-support-writing-to-SharePoint-doc...

Workaround that we have helped with a client was to call a simple batch command in the beginning of the workflow that would delete the drive and then re-map the drive (with credentials provided) each time the workflow was run. Not elegant, but functional.

 

-devKev

 Can you please share the bat file you created? Thank you

Atom

I would like to see that batch file as well as we have same issue. Thanks