Now that it's live, don't forget to accept your certification badge on Credly today! Learn more here.
We are currently experiencing an issue with Email verification at this time and working towards a solution. Should you encounter this issue, please click on the "Send Verification Button" a second time and the request should go through. If the issue still persists for you, please email support@alteryx.com for assistance.

Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Error - Lua open script error: 0 , files and packages not found

carlosmartinezm
7 - Meteor

Hi,

 

I have a scheduled workflow in the gallery that executes another workflow in a network folder via an Event with command line option.

I receive this error message from the execution of the workflow in the network location, I haven't been able to understand the issue from the community discussions:

 

Started running \\filesrv\NIB-path-and-nameof-theworkflow at Thu Feb 20 11:05:23 2020

00:00:0.002 - Alteryx: Running at a Low Priority.

00:00:0.048 - ToolId 149: 173 records were output

00:00:0.078 - ToolId 157: 412 records were output

00:00:0.095 - ToolId 155: 193 records were True and 219 were False

00:00:0.135 - ToolId 195: ODBC Driver version: 03.80

00:00:0.148 - Error - ToolId 195: Lua open script error: 0, D:/Alteryx/bin/RuntimeData/ODBC/sqlncli11.lua:1: module './RuntimeData/ODBC/sqlserver' not found:

                no field package.preload['./RuntimeData/ODBC/sqlserver']

                no file 'D:\Data\Alteryx\Service\Staging\3792_feb91851ee564955b20b7bd2261f368c\_externals\1\lua\\/RuntimeData/ODBC/sqlserver.lua'

                no file 'D:\Data\Alteryx\Service\Staging\3792_feb91851ee564955b20b7bd2261f368c\_externals\1\lua\\/RuntimeData/ODBC/sqlserver\init.lua'

                no file 'D:\Data\Alteryx\Service\Staging\3792_feb91851ee564955b20b7bd2261f368c\_externals\1\\/RuntimeData/ODBC/sqlserver.lua'

                no file 'D:\Data\Alteryx\Service\Staging\3792_feb91851ee564955b20b7bd2261f368c\_externals\1\\/RuntimeData/ODBC/sqlserver\init.lua'

                no file 'D:\Data\Alteryx\Service\Staging\3792_feb91851ee564955b20b7bd2261f368c\_externals\1\..\share\lua\5.3\\/RuntimeData/ODBC/sqlserver.lua'

                no file 'D:\Data\Alteryx\Service\Staging\3792_feb91851ee564955b20b7bd2261f368c\_externals\1\..\share\lua\5.3\\/RuntimeData/ODBC/sqlserver\init.lua'

                no file '.\\/RuntimeData/ODBC/sqlserver.lua'

                no file '.\\/RuntimeData/ODBC/sqlserver\init.lua'

                no file 'D:\Data\Alteryx\Service\Staging\3792_feb91851ee564955b20b7bd2261f368c\_externals\1\\/RuntimeData/ODBC/sqlserver.dll'

                no file 'D:\Data\Alteryx\Service\Staging\3792_feb91851ee564955b20b7bd2261f368c\_externals\1\..\lib\lua\5.3\\/RuntimeData/ODBC/sqlserver.dll'

                no file 'D:\Data\Alteryx\Service\Staging\3792_feb91851ee564955b20b7bd2261f368c\_externals\1\loadall.dll'

                no file '.\\/RuntimeData/ODBC/sqlserver.dll'

                no file 'D:\Data\Alteryx\Service\Staging\3792_feb91851ee564955b20b7bd2261f368c\_externals\1\.dll'

                no file 'D:\Data\Alteryx\Service\Staging\3792_feb91851ee564955b20b7bd2261f368c\_externals\1\..\lib\lua\5.3\.dll'

                no file 'D:\Data\Alteryx\Service\Staging\3792_feb91851ee564955b20b7bd2261f368c\_externals\1\loadall.dll'

                no file '.\.dll'

Finished in 00:00:0.296 with 1 error

 

 

Any idea?

 

Thankss

 

3 REPLIES 3
CJShyne
5 - Atom

I have version Alteryx Designer 2019.1 (We user the Alteryx Server) and I have a similar error and not sure why it is occurring, any update to yours? This module is triggered by a runner module, this version simply has an updated alias to a new connection. Testing worked fine, one off run worked fine, scheduling just this module worked fine. Yet the automated job that this runs with it has errored two days in a row.

 

My error is below:

 

 

00:03:26.982 - ToolId 72: Alias translated to odbc:DSN=CTDataProdGF;UID=APPID_ALTRX_01;PWD=__EncPwd1__|||SELECT * FROM "CBG_ACS_STAGING"."ACCT_LNKG_VW"
00:03:27.257 - ToolId 72: ODBC Driver version: 03.52
00:03:27.264 - Error - ToolId 72: Lua open script error: D:/APPS/Alteryx/bin/RuntimeData/ODBC/SQORA32.lua:1: module './RuntimeData/ODBC/common' not found:
 no field package.preload['./RuntimeData/ODBC/common']
 no file 'D:\APPS\RBDData\Crew Macros\Macros\SupportingExes\lua\\/RuntimeData/ODBC/common.lua'
 no file 'D:\APPS\RBDData\Crew Macros\Macros\SupportingExes\lua\\/RuntimeData/ODBC/common\init.lua'
 no file 'D:\APPS\RBDData\Crew Macros\Macros\SupportingExes\\/RuntimeData/ODBC/common.lua'
 no file 'D:\APPS\RBDData\Crew Macros\Macros\SupportingExes\\/RuntimeData/ODBC/common\init.lua'
 no file 'D:\APPS\RBDData\Crew Macros\Macros\SupportingExes\..\share\lua\5.3\\/RuntimeData/ODBC/common.lua'
 no file 'D:\APPS\RBDData\Crew Macros\Macros\SupportingExes\..\share\lua\5.3\\/RuntimeData/ODBC/common\init.lua'
 no file '.\\/RuntimeData/ODBC/common.lua'
 no file '.\\/RuntimeData/ODBC/common\init.lua'
 no file 'D:\APPS\RBDData\Crew Macros\Macros\SupportingExes\\/RuntimeData/ODBC/common.dll'
 no file 'D:\APPS\RBDData\Crew Macros\Macros\SupportingExes\..\lib\lua\5.3\\/RuntimeData/ODBC/common.dll'
 no file 'D:\APPS\RBDData\Crew Macros\Macros\SupportingExes\loadall.dll'
 no file '.\\/RuntimeData/ODBC/common.dll'
 no file 'D:\APPS\RBDData\Crew Macros\Macros\SupportingExes\.dll'
 no file 'D:\APPS\RBDData\Crew Macros\Macros\SupportingExes\..\lib\lua\5.3\.dll'
 no file 'D:\APPS\RBDData\Crew Macros\Macros\SupportingExes\loadall.dll'
 no file '.\.dll'

Dreinagel
5 - Atom

I am receiving the same error with my scheduled workflows that have file attachments.  When the workflow is ran from desktop I have no problems, the error only generates from the scheduler.  Have either of you resolved your problem?

FJ_Shafeek
7 - Meteor

Bumping as we are hitting the same issue. Same as everyone else, running the workflows manually works just fine, but the automated schedulers are giving that error and not actually running the workflows.