community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

CReW macro error: "SupportingExes\AlteryxRunner.exe" returned an error code: -1073741819

Highlighted

Hello

 

My chain of Conditional Runner workflows which has worked for literally years has failed this morning with an error that's new to me: 

 

The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1073741819

 

(I have another one that also failed today, with error code -1073741818)

 

I've tested the dependencies of the workflow and telling me that the directory doesn't exist, but it definitely does:

 

Crew error.PNG

 

What's going on?  Just to emphasise, this has been working daily, for years 

 

I can see some other threads but both seem unresolved:

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/CReW-Macros-The-external-program-quot-...

https://community.alteryx.com/t5/Alteryx-Server-Discussions/CREW-MACROS-external-program-quot-Suppor...

 

Thanks 

 

Regards

Richard

Alteryx Certified Partner
Alteryx Certified Partner

Was there a recent update on Windows? 

 

There have been issues with different versions (e.g. Enterprise) and possibly with anti-virus.

 

Cheers,

 

Mark

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.

Hi Mark

 

I have checked with the IT support, and am awaiting a response.

 

If there had been, what are the implications, would I need to reinstall the macros or something like that?

 

Thanks

 

Regards

Richard

Alteryx Certified Partner
Alteryx Certified Partner

In the transition of CReW macros, these macros were moved to Alteryx.  They are executables and the source code is theirs.  If you find the root cause (update) as an update to your environment (which I think is where you are headed), sending that information to support@alteryx.com is your best course of action.

 

Cheers,

 

Mark

 

P.S. letting us know would be helpful too

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Alteryx
Alteryx

A little bit left field, but if you have had an update. 

 

Could you remove the runner tool and add and reconfigure it to see if it resolves the issue?

Hi Joe

 

This actually worked for me; I built a new workflow to try and recreate the problem and it worked fine, so I rebuilt the original workflows that had the errors and they started working again :-S

 

For reference, the various solutions and things to check across the threads were:

 

1) Rebuild the workflow afresh with new tool instances

2) Check if the file paths within each macro are correct

3) Restart the server

4) Check if there's been any Windows Updates to the server

5) Check if the "run as" settings are set up correctly

6) Check if there are any 32/64 bit machine mismatches between local Designer and Server

7) Include the location of the AlteryxEngine.exe in the path of system variables on the computer

 

Thanks to everyone else for their help as well

 

Regards

Richard

Meteoroid

I'm running the Desktop Designer and updated to 2019.3 on the same day as installing windows updates and can't seem to resolve this issue.  The one update that doesn't want to uninstall is KB4346783.

 

When I open up the CReW_Runner.yxmc the error (1073741819) comes from trying to run SupportingExes\AlteryxRunner.exe

Alteryx
Alteryx

@nlashinski wrote:

I'm running the Desktop Designer and updated to 2019.3 on the same day as installing windows updates and can't seem to resolve this issue.  The one update that doesn't want to uninstall is KB4346783.

 

When I open up the CReW_Runner.yxmc the error (1073741819) comes from trying to run SupportingExes\AlteryxRunner.exe


Have you gone through the steps that Richard did above?

 

It looks like that error code can be C++ redistributable related after a bit of googling. Has that been updated as part of windows?

 

There is an unrelated thread to Alteryx here: https://answers.microsoft.com/en-us/windows/forum/all/solved-error-code-1073741819-when-running-cert... 

 

But I believe the content may be related to the executable as it will be using C# and/or C++

Meteoroid

I've tried everything except for Including the location of the AlteryxEngine.exe in the path of system variables on the computer as that file does not seem to exist anymore.  I've messed with the C++ distributions and even sound setting as some other people have suggested when they saw the error inside other software but nothing seems to fix it.

 

I reverted my computer to before I had run the updates and before I had updated Alteryx and the runner worked.

I then updated Alteryx to 2019.3, did not run any updates and it failed again.  

 

I'll see if I can replicate this on other machines or if it has something to do with my normal computer.

2019.3 Also caused an error on my laptop.  All these tests have used the same version of the CReW macros so I would assume it has something to do with that Alteryx version.

Alteryx
Alteryx

@nlashinski wrote:

I've tried everything except for Including the location of the AlteryxEngine.exe in the path of system variables on the computer as that file does not seem to exist anymore.  I've messed with the C++ distributions and even sound setting as some other people have suggested when they saw the error inside other software but nothing seems to fix it.

 

I reverted my computer to before I had run the updates and before I had updated Alteryx and the runner worked.

I then updated Alteryx to 2019.3, did not run any updates and it failed again.  

 

I'll see if I can replicate this on other machines or if it has something to do with my normal computer.

2019.3 Also caused an error on my laptop.  All these tests have used the same version of the CReW macros so I would assume it has something to do with that Alteryx version.


I have sent you a PM to help progress this