community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

CReW Macros - The external program "SupportingExes\AlteryxRunner.exe" returned an error

Atom

Hi Adam,

 

Our Alteryx consultants (Inviso.dk) seems to have found the cause of this issue. If you use the List Runner tool on a 64bit machine/Server it will crash if the supporting EXE file is 32bit. This means that the tool will run on 32 bit machines, but not on 64bit. They are working on a fix now. I'll ask them to update the issue with the fix.

 

br

 

Jannik

Alteryx Certified Partner

We have designers running on 32 bit machines and a server running 64bit. This means that the designer will not be able to run the AlteryxRunner (Listrunner, etc. macros). As soon as the workflow is scheduled on the server, it runs perfectly.

 

When there is a mixed 32/64 bit environment in your setup, the current version of the runners will only be able to run on either 32 OR 64 bit. An alteryx runner that checks for whether the machine running the macro is 32 or 64 bit is needed to solve this issue for us.

Meteor

Hey Adam,

 

 

This tool and macro pack has been a MASSIVE benefit to us.  We have the list runner tool embedded in numerous workflows and have been using it daily with success for about a year.  As of this morning, we started getting this error out of the blue.

 

I have a pretty basic set up.  I am just using a 64-bit windows 7 machine.  We just use Desktop designer, no server.

 

 

1.  What version of the Crew Macros are you using? 1.0

2.  What version of Alteryx? 2018.1.3

3.  What version of Windows? Windows 7

4.  32-bit or 64-bit Alteryx? 64 bit

5.  Have the runner macros ever worked on the affected machines? Yes - for about 1 year with no issues

Alteryx
Alteryx

I worked with a user who was getting the same error on their gallery and for them rebooting the machine solved the issue. I'm sure that is not the case for everybody but wanted to share it since it's an easy thing to try! 

Henriette Haigh
Principal Support Engineer, Alteryx
Asteroid

Sorry i know this is super old but can you explain how you did this?  I am having this problem when trying to run the alteryx desktop scheduler from a service account.  Before the EULA police arrive, we are not sharing the license.  Just wanting a service account to run the scheduler as opposed to my personal credentials.

Meteoroid

When attempting to use the Crew Runner macros on Windows 10 Enterprise, I am receiving the attached error related to execution of the AlteryxRunner.exe.  Would it be possible to update this .exe to run successfully on this version of Windows?

 

 

1.  What version of the Crew Macros are you using? 2016 Q2 Release

2.  What version of Alteryx? 2019.1.6

3.  What version of Windows? Windows 10 Enterprise

4.  32-bit or 64-bit Alteryx? 64 bit

5.  Have the runner macros ever worked on the affected machines? No

Meteoroid

Is anyone else experiencing this issue with Windows 10 Enterprise and the AlteryxRunner.exe?

Asteroid

I got this to work by re-pointing the run command tool in the Crew_Runner.yxmc to the supporting exes file. i think we were getting this error because we have the CReW Macros installed via a shred drive location and the relative path logic broke. I am currently testing to ensure this is robust. This is just advice, i don't advise messing with production macros - especially the awesome CReW ones.

 

IGNORE, This just broke other stuff

Labels