Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Analytical App Produces Blank Output File


Hey everyone!


I am currently using Alteryx Designer on a VM, and upload workflows/apps to our Gallery.


When I run a specific workflow in designer on the VM, it produces an output with 24k rows. However, when I run the same workflow after it has been saved to the Gallery, it produces a blank output file. Only with the column headers.


I have a feeling this is because the Gallery doesn't have access to write to the location set in the output tool on the gallery, but no error is produced when the output is generated from the gallery. Just a blank file.  I've tested this by swapping the output tool save location in designer to a shared drive that the gallery doesn't have access to, and the workflow errors. So I'm not sure why the output is blank if security/access is the issue...


Does anyone have any ideas or inklings about this? Pretty stumped...






Typically you see an error when Alteryx doesn't have write access to a particular place. The fact that the schema is coming through is some evidence that Alteryx has access to at least write some data. Are you running it in the Gallery or the scheduler? Also, do you have valid credentials entered in the Alteryx Server System Settings under the Run As section?


I'm running the workflow from the Gallery, without the scheduler. Just manually running it myself at this stage.

Yes - we have had a service account created for Alteryx, and the credentials are entered in the Run As section.


In the app, how do you have your data outputting? Is it through a render or a regular output tool?


Regular Output tool to an Excel .xlsx file. 




My money would be on permissions issues as well... but It might be the permissions on your input files.  If you are getting a blank output, I would bet your output tool is ok.


It is actually that the Output Data tool isn't really optimized to be outputting things for viewing in the Gallery. It can write to a specific file location, which you can then navigate to and you can open the file; however, it won't show much in the Browser window when it completes running. I suggest you check out this training for more information on how to properly use Reporting tools when outputting to the Gallery.


When you uploaded your app/workflow, which workflow assets did you include? You may want include the output spreadsheet and see if that makes a difference. Also, enable event in your workflow and send yourself an email containing the app results so you can debug.




Turned out that the service account didn't have access to the directory I was saving the file to :)