Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer and Intelligence Suite.
SOLVED

Problems Using Jira Iterative Macro

RonGatmaitan
8 - Asteroid

Hi all,

 

I keep getting this "No valid fields were selected" error, even though I just left the fields column at "all".

 

RonGatmaitan_0-1647547939504.png

 

I keep getting the same error, even if I try to replace it with an actual field.

 

I tried running the macro, replacing the input with an Input Data tool, hoping to isolate the problem and this is what I get - couldn't resolve host name.

 

RonGatmaitan_1-1647548183107.png

 

In the input Excel file, I only replaced:

- The value of "Project" in the Query column. I replaced it with the Project ID as shown here:

- The User column (with my email address used to access Jira)

- The Project column, from the same value I got from the process above

- The Pass column generated from Jira. I'm a site admin.

- The Site Base, with our Jira domain.

 

 

Help, please.

 

 

Thank you.

Ron

2 REPLIES 2
danilang
18 - Pollux
18 - Pollux

Hi @RonGatmaitan 

 

The "Couldn't resolve host name" message means that the value in the URL field passed to the download tool didn't contain a valid URL.  It needs to be correctly formed "https://site.jira.com".  Also make sure that you filter out the second line from the example file, since it contains only descriptions and not valid values.

 

Dan      

RonGatmaitan
8 - Asteroid

Filtering out the second line from the example file did the trick. Thank you, @danilang!

Labels