Early bird tickets for Inspire 2023 are now available! Discounted pricing closes on January 31st. Save your spot!

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer and Intelligence Suite.
SOLVED

PDF Input tool Error Message

AT_AYX
8 - Asteroid

Hi everyone,

 

I tried the PDF Input tool found in the gallery and I stumbled upon this error : "PDF Input (14): BatchPDFInput (26): Record #1: Tool #2: Error: .onLoad failed in loadNamespace() for 'pdftools' ".

 

So I followed a link for solving the issue and installing the missing R package from the gallery.

 

However, the error still persists and I was just wondering why it didn't work.

 

Please, if you could help me resolve the issue.

 

 

Link:  https://www.youtube.com/watch?v=0aM9YqC1Uuo&t=123s&ab_channel=NathanPatrickTaylor

PDF Input: https://gallery.alteryx.com/#!app/PDF-Input/5b685aff0462d710907f7a3b  

Installing R packages: https://gallery.alteryx.com/#!app/Install-R-Packages/5d9264328a933711e447387c 

Snapshot:

 r.PNG

13 REPLIES 13
Gualigee
8 - Asteroid

I am running into the same problem. 

Gualigee_0-1667068757247.png

I did not see a file called rcpp. @someotherguy @OllieClarke Thank you!

OllieClarke
14 - Magnetar
14 - Magnetar

Hi @Gualigee 

 

RCPP is another R package which needs to be updated if you've upgraded Alteryx. As has been mentioned in this thread by myself and @AnthonyFic the upgrade in R versions requires an update in a number of packages. 

The easiest way to do this is to find the version of R installed with your version of Alteryx ("C:\Users\[username]\AppData\Local\Alteryx\R-[r version]\bin\R.exeon a non-admin install). Double click R.exe to run it and then use the command

 

update.packages()

 

This will then ask you whether you want to update all the packages installed. I said yes to all of them, but the 4 required are (from @AnthonyFic's post)

pdftools

qpdf

tesseract

Rcpp

 

This should fix your problem

 

edit:

The reason you don't see Rcpp in your R-library, is that (I believe), for packages installed by default rather than installed by users, the filepath is: "C:\Users\[username]\AppData\Local\Alteryx\R-[r version]\library"

Gualigee
8 - Asteroid

Thank you for your reply, @OllieClarke 

Gualigee_0-1667221446298.png

I clicked on the above icon. After I ran the command, it says "pdftools will not be updated". 

Gualigee_1-1667221496973.png

They kept asking if I needed to installl this and that but I need not see the following:

qpdf

tesseract

Rcpp

Can you please advise what I should do next?

Thank yo u very much.

 

OllieClarke
14 - Magnetar
14 - Magnetar

@Gualigee it looks like you've got multiple R versions installed, and multiple libraries too. That's not an issue in itself though. Once you've updated the packages, and tried to use the PDF Input tool in Alteryx, what happens?

Labels