Looking for Starter Kits? Head to the Community Gallery! Now formatted as YXIs for easy installation.

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

reading multiple xls schedule error

8 - Asteroid

Hi mates,


I have created a workflow for automating the daily activity.

source files is xls files and i used a macro for reading the multiple xls files attached below.


I am able see the results when i execute manually as shown below



But when i am scheduling the same workflow i am getting error like ( Designer x64 Tool #1: Tool #3: Record #1: Tool #33: File not found "C:\ProgramData\Alteryx\Engine\Engine_1616_27098c8e092a45599db8185602342c14_\XLStabs1.txt")


Also i tried both the options while scheduling In db and local path options

Tried in advance settings--> workflow dependency--> selecting UNC  , but the error remains still same.

I am not understanding how does it matter when manual execution working but not in scheduler.

Note: Not all the workflows failing, only workflows wherever i am using xls macro coming an issue.can someone help me with some thoughts to resolve the issue.



Alteryx Alumni (Retired)
This would be because Scheduler cannot use mapped drives.
The Scheduler runs in session 0, which doesn't load mapped drives.
You'll need to convert to a UNC path. Instead of C:, something like \\machine\folder\data.xls.
There is a good explanation by Alteryx engineer:
8 - Asteroid

Hi @junyak ,


I have converted the path to UNC for all the macros in  mapped drives but still get the same error, is there any other way to resolve the same.