Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

download issue for the MACRO PublishToTableauServer



when I am trying to open the macro PublishToTableauServer_v2.0.0 after downloading in from the website by alteryx (as admin) from 

File --> Open Workflow --> browse then selecting PublishToTableauServer_v2.0.0.yxi

the following interface appears :


after clicking in install with the option for all use .. NOTHING happend 


I have also tried to install the marco directly from the website within alteryx designer from Options--> download predictive tools then within my account , unfortunately I found the macro disabled, as in the following :



Actually I need the macro in order to work with some old workflow for a project i am working it , an when i tried to open one of then i got the following :


need your help

best Regards 

Amira Isbel 

19 - Altair
19 - Altair

Hi @AmiraIsbel_DBSYSTEL 


After I installed this running Alteryx as admin, the Publish to Tableau Server tool shows up in the Connectors palette.  There was no indication that the installer was successful though.  





thank U @dan

the issue is after dowloading the component I have noticed the what i have downloaded is different from from the old now ! and I dont know what to do , 

please have a look 


8 - Asteroid

1. Install the download tool only in Admin mode

2. If any issue check in 2 folders -

   C:\Users\<username>\AppData\Roaming\Alteryx\Tools - If the tool is installed on this location then you might the ?

   C:\ProgramData\Alteryx\Tools - If installation is correct

3. ? means the macro cannot find the file in the location - easy way is to have the Macro in same location between users or workflows

4. In case of issue delete all the instance of Tableau - restart again - Open Alteryx in Admin mode ; Install Tableau to all users , Follow the same installation folder for everyone




19 - Altair
19 - Altair

Hi @AmiraIsbel_DBSYSTEL 


It looks like the person who made the EBIT workflow originally had the PublishToTableauServer macro installed in different directory from yours, so the reference in the file points to the wrong location.


You should be able to fix the workflow like this.


Warning:  This technique involves directly editing the xml in the .yxmd.  Make sure you have a backup of the file before attempting this


Part 1.  Find the correct paths for the macro location on your computer

1. Create a new workflow called MacroLocation.yxmd

2. Drop the PublishToTableauServer onto the canvas

3. Save the workflow

4. Open this workflow with a text editor.  I use Notepad++ but Notepad.exe will work fine.

5. Search for the following line.     

<GuiSettings Plugin="PublishToTableauServer_v2.0.0">

   This should find the xml node that refers to the Publish macro

6. Within this node, find the EngineSettings element.  It's probably the last element in the node. Mine looks like this.

<EngineSettings Macro="PublishToTableauServer_v2.0.0\Supporting_Macros\PublishToTableauServer.yxmc" EngineDll="Macro" EngineDllEntryPoint="PublishToTableauServer_v2.0.0\Supporting_Macros\PublishToTableauServer.yxmc" />

  Yours will probably have a different Macro and EngineDLLEntryPoint

5. Copy this entire line including the opening "<" and closing "/>"  


Part 2.  Find the reference in the broken file

1. Make a copy of 20190509_EBIT_V11.5_FZI_DEV.yxmd

2. Open the copy with a text editor.  

3. Find the EngineSettings element for the Publish macro using steps 3 and 4 from part 1

4. Replace this entire line with the copy you made in part 1

5. Save the file copy

6. Open the file copy in Designer


This should fix your problem.  If it does, rename the copy to something official sounding and use it from now on.  If not, post the results here.  





thank you for your feedback 

actually problem has been solved by downloading old version of the macro and spacifiy which marco to use within alteryx interface ,


Best Regards 

Amira Isbel