We’ve extended Inspire Early Bird Pricing until March 1. Register now and enjoy 20% off conference passes and 10% off training passes. P.S. Don’t forget to bring friends! When you sign up for five or more tickets, you get an extra 20% discount on conference passes. Learn more now.

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.
SOLVED

Update the Python Packages like pandas

Inactive User
Not applicable

Hello guys,

Is it possible to update the python packages in the python environment?
After I import my programm it gives me an error when I try to load a pickel data:

AttributeError: Can't get attribute '_unpickle_block' on <module 'pandas._libs.internals' from 'c:\\program files\\alteryx\\bin\\miniconda3\\envs\\designerbasetools_venv\\lib\\site-packages\\pandas\\_libs\\internals.cp38-win_amd64.pyd'>

 After Searching to solve this problem I think that I have to update the packages. But it does not work with %pip install --user pandas==1.4.1 :( 

Can you help me? 

3 REPLIES 3
DavidSkaife
13 - Pulsar

Hi @Inactive User 

 

This guide may be of help if you want to install the packages via the command prompt (and have the right permissions!) - https://community.alteryx.com/t5/Alteryx-Designer-Knowledge-Base/Install-Python-packages-via-command-prompt/ta-p/611877

 

Inactive User
Not applicable

Hi @DavidSkaife 

 

Thanks for the response. But unfortunately, it does not work. I updated the packages but when I check the version in the Jupyter Notebook it is the old version and not the new. I restarted Alteryx and my PC, but it does not work.....

DanFlint
8 - Asteroid

@Inactive UserHave you tried installing directly through the python tool?

You can use this to install a specific version of your required packages:

Package.installPackages(['pandas==1.4.1'])

If you run into permissions issues, you may need to include the --user tag:

Package.installPackages(['pandas==1.4.1'], install_type="install --user")

Some good information about installPackages can be found here - https://community.alteryx.com/t5/Alteryx-Designer-Knowledge-Base/How-To-Use-Alteryx-installPackages-in-Python-tool/ta-p/406244 

Labels