We’ve extended Inspire Early Bird Pricing until March 1. Register now and enjoy 20% off conference passes and 10% off training passes. P.S. Don’t forget to bring friends! When you sign up for five or more tickets, you get an extra 20% discount on conference passes. Learn more now.

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

SharePoint List Input limitations

8 - Asteroid



I'm having issues loading data from one of my sharepoint lists.

It worked fine for quite some time, but now I cannot select any view in the setup which makes the tool return an error "List and View may not be blank"


Other lists available under the same URL work fine, and I'm suspecting the list somehow went beyond the tool's limitations. It has 174 rows (which should not be an issue) and 45 columns (some of which were added recently).


Does anyone know what the limitations of this tool are, does it break when there are too many columns or columns of certain type?





11 - Bolide

 The size of the data you mentioned (174 Rows and 45 Columns) is not an issue for Alteryx. I would look at the below community post where a similar issue was solved. If the below does not help, could you please post your workflow and a screen image of the error? 



For the lists that do not populate with views, hard code the XML:


1. Go to your configuration and make sure there is the XML logo on the left (</>). If you do not see that go to Options > User Settings > Edit User Settings > Advanced > Check Display XML  in Properties Window.

2. Click </> and hit edit in the top right

3. Your username, password and lists should be populated already but there is nothing for view

4. Insert this line of code <View>ViewName</View> (ViewName is the View you are looking for)

5. Sample to make sure it works <RowLimit>10</RowLimit>

6. Run




ACE Emeritus
ACE Emeritus

Hi @MichalK,


We spoke about similar topic a while back: https://community.alteryx.com/t5/Alteryx-Designer-Discussions/SharePoint-list-Input-fails-in-Gallery...


There is a know and official limitation of 5000 records, this reflects in UI functionality for filtering and general usability of the list and also reflects in Alteryx connectivity, to retrieve more records (the theoretical record limit counts in millions as there is a SQL Server database running in the background) you'll need to batch in under different views or use Microsoft's REST API - also using batch method of up to 5K records at a time. 


Your list does not qualify for the above, however i noticed the exact same problems with extended number of columns - my largest list features over 60 fields and is fed from SalesForce.


I have to batch records 10 at a time (i played with this back and forth and settled for 10 as an optimal number) - for this i concatenate all my headers and records into 2 fields and unpack this inside a macro for processing (ignore the error on the 2nd screen - it reflects schema change in my list, which i had to implement just recently).



8 - Asteroid

I found that the reason why the input stopped working were custom view using datasheet view I set up on the list.

Once I removed it, the tool allowed me to select a view and is back working.