Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Sending HTML Email with Email Tool

Inactive User
Not applicable

I haven't had any success attempting to send a HTML format e-mail using the Alteryx E-mail tool.  The tool doesn't recognise when the body is HTML or provide the option of configuring the tool to send the e-mail as HTML format.  As a result the HTML gets sent as plain text. 


The render tool can be used to render the HTML into an image and passed into the Body of the Email tool however this means that an image is sent rather than HTML and the href links can't work.


I'm currently sending e-mail using the bmail command line client (in a Run Command tool) so that e-mails can be sent as HTML.


Has anyone else experienced this problem or found a solution using built in tools?

6 - Meteoroid

It sucks to have to downgrade to regain functionality that we have relied on for so long. We use Alteryx for so many processes that output HTML formatted emails using this method. 

8 - Asteroid

Hey guys! I was wondering if this was still an issue whereby the workaround won't work on the most recent versions of Alteryx? I've tried the method but it's just sending a blank email - did anyone manage to figure out a new way of achieving the html email? 


Currently moving images of rectangles around to try to create some level of customisation looks awful haha

11 - Bolide

It seems 2020 builds removed this work around.  (?)  We have written an integration to SendGrid to get there.  

9 - Comet

Hi @brianscott , have you done any more testing on this? I tried using 2020.3 using the <![CDATA... trick and I'm not having any luck.




7 - Meteor

Hello @brianscott, Hey @jdrummey !

I was wondering if there was a workaround since the 2021?

Best regards,


9 - Comet

Hi @Jérémie , I haven't tried...when I need to send HTML emails I've used other tools.

6 - Meteoroid

We too rely heavily on using Alteryx to send HTML emails and are forced to be stuck on Designer 2022.1.1.25127 to ensure this functionality doesn't break.