Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Python Tool Not Starting Jupyter Notebook in Alteryx

8 - Asteroid

Is anyone else running into the problem where the Jupyter Notebook is not loading for the Python tool in Alteryx?


After following the steps in the Alteryx Tool Mastery - Python (link below), the Jupyter Notebook fails to load. Only a blank screen appears in the sidebar, after the "To instantiate the notebook in Designer, just wait" message disappears. See screenshot.



Attached is my Python test workflow. I have tried using the Python tool in "Admin" and "Non-Admin" version of Alteryx 2019.1. 


Any advice on what I am doing wrong? Is there a setting in Alteryx that needs to be switched?


Hi @Brian_Stoffel ,


Have you tried right-clicking your Designer, click "Run as administrator" and re-run the workflow again? The Python tool should appear (worked for mine). The tool requires Alteryx to be ran in an elevated state.




8 - Asteroid

I ran the workflow after right clicking on Designer and clicking on "Run as administrator" but the same blank screen appears for the Jupyter notebook. 


I also signed into my computer as the administrator and repeated the above steps and received the same blank screen. The notebook didn't initiate. 


It is as if something is blocking the Jupyter Notebook from initiating. 


Lastly, both the "interactive" and the "production" sections fail to load in the Python tool. 

5 - Atom

Has anyone found a solution?  This just started happening to me and I am totally blocked from using the Python Tool, which I have been using successfully for months.  Suddenly I can't see anything in the left panel.  Problem occurs in both 2018.3 and 2019.1

8 - Asteroid


I have updated to Alteryx version 2019.2.5.62427 and the issue has resolved itself.

5 - Atom

Hi I have the same issue where the configuration pane does not load we have the latest version 2021.1, I did try opening the app with admin rights but still does not work. any help would be greatly appreciated.


9 - Comet

Greetings - I have a user where this is happening, while using Alteryx Designer v2020.1.5.  The application worked fine up until a few weeks ago, and now the Jupyter Notebooks refuse to load for any workflow using the Python Tool.  We have tried creating both a simple workflow and a full process with the same results.  We have attempted to reinstall Alteryx Designer on the workstation with no results.  So far this has been isolated to only one Alteryx Designer user.  Is there any suggestion on how to correct this issue?



Kevin J

8 - Asteroid

Update. This issue seemed to have randomly resolved itself without any changes to my Alteryx Designer. I can now run the Jupyter interactive notebook in the Python tool within Alteryx.


One possible solution is that I installed Python 3.10 to edit/run Python code in Visual Studio Code. Might be related or might not.

5 - Atom

Currently I'm facing this same issue
tried running as administrator
Antivirus blocking checked
Reinstalled the designer
Using latest version of Alteryx Designer

Any help will be appreciated

9 - Comet

Go to C:\Users\[user]\AppData\Roaming\Python\Python38 and change the name of the 'site-packages' folder to 'site-packages_old'. Then restart your Alteryx designer.