Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Need help how to use XGBoost in Gallery

6 - Meteoroid

I download the 'XGBoost Python & R' from Predictive District in Gallery,  I faced the following error when I ran it in Designer.

My designer is version 2019.1, and the RInstaller 2019.1 has been installed as well. Can any expert help me slove this problem?

Thanks a lot.




6 - Meteoroid

I attached file XGboost package that I downloaded from the Predictive District of Gallery.   I think I miss something to be installed, right?  can you help? thanks.

6 - Meteoroid

I'm wondering some library has not been installed, please find the error msg from below screen copy,  can you help how to fix it? thanks.XGBoost-Error2.png

Alteryx Alumni (Retired)

When open the Alteryx package, you need to install the library like (xgboost, readr, etc) for both R & Python macro to work. Here are the links for R & Python guideline if you are new to this, look for the error message then install the corresponding library.



6 - Meteoroid

Thanks TimothyL, yes it need to install related library but there were some more problem when I try to install the library at that time:


pip install xgboost==0.71
Files/directories not found in C:\Users\[me]\AppData\Local\Temp\pip-install-fh91enpk\xgboost\pip-egg-info

And then I found the notice from GitHub as following:



  • Windows users: pip installation may not work on some Windows environments, and it may cause unexpected errors.

    Installation from pip on Windows is therefore currently disabled for further investigation; please install from Github instead.

finally I install the pre-build binary code using

pip3 install xgboost

 then xgboost has been installed sucessfully.  thanks.


7 - Meteor

@wilburwen838 I am stuck at the same point. I am using Alteryx 2018.4. Can you please let me know where you added this piece "pip3 install xgboost" in the macro and ran successfully? Thanks much.




I tried installing the "readr" package using "Install-R-Packages" and it didn't work. Please find my post at the end of the below thread

Alteryx Alumni (Retired)

What Wilbur referring is the Python Tool. This post contains both Python & R tools. Please clarify which environment you are working on and install the required library accordingly. 


For pip3, open the python tool with designer (admin), you should be able to install the package