Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Microsoft oledb sql server error

7 - Meteor

Hi all,


I am getting some weird error when I tried to give a SQL server as a data source. I am using altery 11.7 version, very recently i have updated alteryx designer before it was working.

Anyone help me to fix this issue. Please find the attached document for error.








Alteryx Alumni (Retired)

Hi @DeepakKrish,

Check to see if you are using the SQL Native Client driver.  It appears you are using the MS OLEDB provider instead and the issue will probably resolve if you reconfigure you DSN using the native client driver.

7 - Meteor

Hi @WayneWooldridge


As far as I am using MS oledb for SQL provider and I have reconfigured the DSN also , but still i am facing same issue.

Alteryx Alumni (Retired)

Which anti-virus software are you using?  I was able to find a lot of information on the web about that particular error and the most helpful seems to be related to anti-virus installations:


"antivirus seems to randomly conclude that the comms between client and server via TCP/IP is a Trojan Virus at work and stops it. I turned off the firewall and it appears to have fixed the problem."


"when I looked at the Event Viewer and found that Nortons was causing the problem. Have a look there and it may help you find the problem. In my case I changed to Trend Security and the problem never re-appeared.
Start>Control Panel>Administrative Tools>Event Viewer>System"


I'm not sure which version of SQL Server you are using, but thought this might apply to you if you're using 2005 or 2008:


"You get this error because SQL Server 2005/8 Express, Express Advanced and Developer comes with most features disabled by default. In 2005 you have to go to SAC(surface area configuration tool) to enable TCP/IP and Named Pipes, enable local and remote connection. And in 2008 you go to Configuration manager and enable same. "


The full conversation around this error can be found here:

8 - Asteroid

I got the same error and I found out that when you create the oledb saved connection data Source=address\dbname loses the \ -character between the server address and dbname. You can add the missing character manually just before saving the connection.