Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

In-Database Error - The object name is too long in NFD/NFC when connected to Teradata

7 - Meteor

I get the below error message in my workflow when doing any of the following: 

  • Using the Filter Tool to peform any column based filter eg apply IS NOT NULL on a column
  • Using the Data Stream Out Tool to the standard select tool
  • Using the InDB Browse Tool


Error: Data Stream Out (57): Error SQLPrepare: [Teradata][ODBC Teradata Driver][Teradata Database] The object name is too long in NFD/NFC.

7 - Meteor

I have discovered the problem


The object name is too long in NFD/NFC when connected to Teradata Error occurs when you use SQL comments above the SELECT statement within the Connect In-DB customer query box. Once the comments are removed the problem is resolved. Pity I cant use comments though. 

5 - Atom

Have the same problem, Filter, Browser, give "the object name is too long in NFD/NFC" error

The exact sql query works fine in Teradata, used recursive query to get the hierarchy.

And I have removed all comments in sql.

What can be the other reasons?

Any thoughts? 

7 - Meteor



Looks like nobody addressed your issue. I have ran into the NFD/NFC issue many times in Alteryx and has nothing to do with comments. Your issue and the same I run into often is with Alteryx's SQL editor as it inserts or modifies the characters, especially with spaces by compressing.  It has been an editor issue since day one.


To resolve, edit your SQL and make sure you insert spaces after each line, especially the "SELECT", I guarantee that is causing your issue.  Now we can close this out.




9 - Comet

Hi, I am getting the same error. I don't have any comments in my SQL and I made sure there were spaces after SELECT and for each row. Any other ideas?

5 - Atom
It happens with In-Dadabase connection with Teradata only, when I switched
to regular module, the error is gone in my case.
6 - Meteoroid

I'm new to Alteryx. I have the same issue, Can you help me understanding what is regular mode to connect to Teradata? (I made sure there are enough spaces and no comments as well)


Appreciate all your help!

6 - Meteoroid

No worries! removing spaces between the columns helped! Looks like Alteryx is having a character limit in the SQL Editor.

5 - Atom

I've had various forms of this issue which fall into two categories:


Comments: just generally delete / move these from the top of the code


Tabs/spacing/etc: this can be misinterpreted


Solution: use another tool to check formatting (I use freeware Notepad++ ) and then copy over with no formatting clear spaces and no tabs

7 - Meteor



I have tried to remove comments, extra blank lines for the Connect In-DB tool, but still get the same error in the Filter In-DB tool.  Is there a characters limit to the SQL query?

The original query worked but I am making some changes to it.

Thanks in advance.