Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Hyper write issue

8 - Asteroid

Hi Community:


I don't see this topic out there so I want to start it up.


I have a workflow that was previously writing to a TDE, but now with the advent of 2018.1, I can write to Hyper! 


While this is quite exciting, my first stab at it has left me with less-than-stellar results. Here is the logfile result:



Start: Designer x64: Started running [...]\1 Alteryx\1.1 flows\ Add Salesman descriptors and inbound.yxmd at 03/14/2018 11:00:23
Error: Designer x64: The Designer x64 reported: InboundNamedPipe::ReadFile:  Not enough bytes read. The pipe has been ended.

End: Designer x64: Finished running Add Salesman descriptors and inbound.yxmd in 42.8 seconds with 1 error and 3 warnings



I've identified that this is my hyper file by turning off my outputs (using that cool new disable toolbox thing in the top-left corner of my tool container! YES!) and running it. If I don't write to that hyper file, I'm fine. I tried making a secondary hyper file and it still didn't work. Although the hyper files actually do write to the directory, they're unreadable in Tableau 10.5.1.


The real issue I was having was that it screwed up other files (the YXDBs) I was writing to, rendering them useless to other flows. Again, if I run it without writing to the hyper file, I'm fine. But if I write to hyper and write the YXDB, here's the error I get from the incoming flow:


Error: Input Data (126): [...]\ Output- Sales with OD pairs and Salesperson names.yxdb 
The FileID does not match in the FileHeader.

Hoping this helps the team in identifying fixes.






8 - Asteroid