Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Error transferring data: Failure when receiving data from the peer

6 - Meteoroid

Hello Community,


I had built a couple of workflows to scrape a few websites.

All of these worked and was able to extract the data I intended to.


A few months later when I am trying to run these workflows (without any modification), I get the below error:

Error: Download (3): Error transferring data: Failure when receiving data from the peer

All the workflows are now throwing the same error at the download tool.


Could you please point me, what should I look for to fix this issue?


I have attached one of the workflows and below is the error screenshot.




Thanks and Regards,



14 - Magnetar
14 - Magnetar

Have you tried sending headers; like the User Agent?

If you are getting checked by a bot-block that can help.

To determine what headers to send, download Fiddler ( and visit the website through a browser.

You should be able to see all of the necessary headers in the Fiddler capture log.


5 - Atom

Thanks Patrick,


This did the trick for me. I was having the same issue and struggled with it for few mins before searching the forum. Disabling the auto proxy worked well and I can dump the salesforce data into a table

8 - Asteroid

I am getting this same error but it's while using the reverse geocoding macro.  I ran the macro on our development server and received the error once but it went away when I reran the application.  I then moved the app to the production server and this error shows up again.  This time it will not go away with re-running.  Any ideas?  I have a list of spatial objects that feed into the reverse geocoder.  Their output is limited to the Lat/Lon Output under 'Select output fields' and Preserve input fields under Additional Options.





14 - Magnetar
14 - Magnetar

@brad_j_crep  Can you clarify which error and which tool it occurs on?

8 - Asteroid

Yes, thank you.  The "Error Transferring Data: Failure when receiving data from the peer"  error.  And it's located in the reverse geocoding macro at Tool #23 which I cannot access to give you the tools name.  It seems to be something between the tool and the server running the tool.  I did get the error on a development server but it 'went away' and did not show up again after server runs.  It's when I moved it to this server that the error comes up and will not work itself out.


Any ideas?


Thank you!


Hi @brad_j_crep


Check out this post by @PaulN, it may help to resolve the error you are seeing.  It is written for the UK Geocoder, however, the Reverse Geocoder works in exactly the same manner.





8 - Asteroid

I'm checking on the whitelist like PaulN's posting said.  I think that is probably the answer.

Thank you,

7 - Meteor

Like many companies we have proxy servers.  Once I turned off the proxy servers in "Internet Options" the process works perfectly. Very unusual sine I have to have them on for everything else.

6 - Meteoroid

I had a similar situation with the download tool and was getting the same error (on things that had previously worked).


The FIX was simple.  It was the USER SETTINGS / ADVANCED / Enable Proxy Credentials (set up your internal corporate proxy).


The Alteryx session was not getting out to the external network to retrieve the data for the download tool and updating the proxy settings fixed that.


Hope this helps.



8 - Asteroid

This worked for me, simple fix. I was attempting to pull SDN list from Dept. of Treasury website and was receiving error. Added my company credentials and it worked, thanks Sutton!