Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Error : Publish to tableau server - select an existing project

6 - Meteoroid



I'm having an issue with the Publish to Tableau server tool version 2.0.0 (using Alteryx 2018.2 and Tableau server 2018.1)


I've installed it from the official gallery. I've signed in to the Tableau server without problem, then went to the "Configure Data Source" part. I can see the projects, I can enter a data source name, choose the output options and data source format . everything is fine. When I validate, I get an error message "Select an existing project".


Of course the workflow won't run.. but I can't access the configuration anymore. There is a  spinning circle that never stops and the configuration panel is not accessible. All I can do is deleting the object from the workflow.


I've installed previous versions of the tool. So just after dropping it on my canvas, I can right click and select the version (1.09.2 or 1.08.1). Both versions work and allow me to publish to the server, in .tde or .hyper, which is what I want...


Maybe a next version will solve this issue, but if there is a solution to it, I would be interested in knowing it.


thank you

5 - Atom

I get this exact same bug, also have previous versions of the tool installed.

8 - Asteroid

The same for me with the latest version of the macro.

Hope you could find what is happening.

8 - Asteroid

The same for me with the latest version of the macro (Atleryx 2018.2 and Tableau Server 10.5)

Hope you could find what is happening.

Alteryx Alumni (Retired)

@Julien_B @Philimor @CliveM


Thank you for posting, we are currently looking into this. Do you happen to have apostrophes in your data source names? If so, can you try removing any apostrophes from the data source names and see if this resolves the issue?

Jake Samuels

Principal Support Engineer
Alteryx, Inc.
6 - Meteoroid

Hello JakeS,


Sorry for the late reply...


No i'm not using any apostrophe in the data source name. I've tried with a new data source 'test', on a new workflow with just input/output with the same unsuccessful result.

6 - Meteoroid

I am also having this issue.


I have tried to resolve this but there seems no way to resolve it at the moment.


Anything to resolve this would be helpful.

7 - Meteor

Same issue here using tool version 2.0, Alteryx 2018.2 and Tableau Server 10.5.2. Removing the tool, adding it back and reconfiguring the connection produces the same message time and time again. A project folder had been chosen and recognized during the configuration process, just not after you click outside the configuration screen.

5 - Atom

The same thing was happening to me.  I kept trying to run it and despite the error still showing and the configuration not refreshing properly, it did run and I saw  the data in Tableau.  Now it seems fine.


8 - Asteroid

Hello JakeS,


I am also having the same issue like everyone else in this discussion. So is there a solution to this? Has the tool being fixed?