Dev Space

Customize and extend the power of Alteryx with SDKs, APIs, custom tools, and more.
SOLVED

Unable to find the Configuration File error

IraWatt
16 - Nebula

I created a tool using the alteryx-tool-generator which was recommended in the docs Engine and HTML GUI SDKs | Alteryx Help . this generated this file structure:

IraWatt_0-1656348522003.png

I didn't change any of the files I just ziped the file and changed the extension to .yxi.

IraWatt_1-1656348638095.png

When I try to run the file I get this error in Designer:

IraWatt_2-1656348668472.png

Not sure why it cant find the configuration. I've attached the zip file. 

 

4 REPLIES 4
tlarsen7572
11 - Bolide

Everything except Config.xml needs to be in a folder. The folder should be the name of the tool. Your file structure should look something like this:

tlarsen7572_0-1656349475115.png

 

YXI's are designed this way because a single YXI can install multiple tools. Config.xml is the config for the overall YXI file. Each tool in the package gets its own folder and its own files.

IraWatt
16 - Nebula

Hey @tlarsen7572 thanks for getting back, I did think it was strange it was all in one directory. I tried your file structure but I ran into the same issue. Looking at the base config file the details look a bit sparse compared to the tool config. Does the root config look alright to you? 

IraWatt_0-1656350142892.png

Many thanks,

Ira

 

tlarsen7572
11 - Bolide

Typically, the root config file will be sparser. I tend to just copy my tool config and use it as the root config, but that's because of laziness.

 

If you are getting the same error, my guess would be that the folder structure is still not correct.

 

How are you generating the zip file?

 

You need to be careful that Config.xml and the tool folder are in the root of the zip file. When I generate the zip file, I select Config.xml and the tool folder, right-click, and select 'Send To'->'Compressed (zipped) folder'.

tlarsen7572_0-1656351821702.png

 

 

IraWatt
16 - Nebula

I was zipping the root directory entirely 😫😵 ! thankyou for all your help today @tlarsen7572