Showing results for 
Search instead for 
Did you mean: 

Dev Space

Customize & extend the power of Alteryx. SDKs, APIs, custom tools, and more!
Announcement | We'll be doing maintenance between 9am-11am MT on Saturday, January 25th, which may impact your experience. Thanks for your patience as we work on improving the community!

Publishing workflows with encrypted password to the Gallery


When I try to save a workflow to the Gallery, I get an error: 



RuntimeError: InternalError: DecryptPassword - buffer too small.


this error happens in Python SDK's decrypt_password and on the client I use the following to encrypt:


.postJsEventWithCallback('Encrypt', { text: this.state.apiToken, encryptionMode: 'machine' }, function (encryptedToken) {


I've noticed that Saleforce Input Tool uses the same method of encryption, but I don't get the same error when publishing workflows using it. 

How can I achieve the same with my tool?



Hi @pavloko, this looks like it could be a defect. Do you get this error when you run the tool in Designer or is it isolated to Gallery runs? Can you share the source code for your tool with  me?


I have similar issue, it's the salesforce  input tool. The workflow I created stored with my salesforce password, when I share it using "Simplicity", a software for sharing within the company, when run on the server, shows these error. I have some old salesforce input tool, those tool works. The new version has this issue. 


Because of the encryption methods we employed between the HTML GUI SDK and the Python SDK, tools built with those SDKs (like the latest version of Salesforce Input) cannot be scheduled or uploaded to the Gallery when there are encrypted fields present. The same limitations apply to other sharing software where the server is remote. We are working on alternatives that will allow users to do this, but I don't have a time frame for when it will happen.


Hi @BlytheE 


I was just trying to publish a workflow with an Salesforce Input tool to a Gallery and got the same error (please see below). Has this issue been resolved or do you have a workaround?


InternalError: DecryptPassword - buffer too small






Hi @vutmo - unfortunately, I do not have any time frame for when this will be resolved. A potential workaround is to configure the tool on the Server and then upload it from the Server, however, that may not be feasible and depending on your deployment, it still might not work.


Hi @BlytheE  - can you expand on your reply? 

We are getting this error with the salesforce input tool running from gallery:


Traceback (most recent call last): File "", line 73, in pi_init RuntimeError: DecryptPassword only works with User and Machine encrypted passwords. (Tool Id: 36)


Does the DEPRECATED salesforce input tool work correctly?


This issue only applies to tools with an HTML GUI SDK frontend and Python SDK backend (like v4 of Salesforce Input). The deprecated versions do work on the Gallery and can be scheduled because they don't have a Python backend. 


Hi @BlytheE 


The deprecated Salesforce tool seemed to work on Gallery. What are the caveats of using the deprecated versions vs. the v4 Salesforce tool?


Thank you!




Hello @vutmo - we added the ability to pull reports in v4 and you can query for deleted records from tables. Other than that, the functionality remains the same.