community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Workflows schedules failing intermittently

Highlighted

I have two workflows setup in a way when first workflow is successful it triggers second workflow to run using AlteryxEngineCmd command in the Event (After Run without Errors) in configuration panel. 

When I schedule the first workflow to run at certain times like every 5 mins , sometimes it gets successful and sometimes it fails. 3 out of 10 runs are successful. Same thing happens when I run it on Alteryx Designer, if first run is successful, second run fails and again 4th or 5th run gets successful. 

When I tried to run it directly on command prompt same thing happens, but in command prompt I get to see error where it says "The Feature "API or Flowchart Mode" is not licensed. As I said, it does get successful sometimes even in command prompt though.

 

When workflow is unsuccessful in Designer mode, it throws this error "Error: Designer x64: The Designer x64 reported: Error running Event #2: The external program "C:\Program Files\Alteryx\bin\AlteryxEngineCmd" returned an error code: 2: The operation completed successfully. (0)", Here also workflow do get successful sometimes without changing any configuration or tools.

 

This is very weird scenario as schedule and runs through Designer/Cmd does get successful sometimes and sometimes it does not. If anyone has encountered such issues and if you could shed some light on this that would be much appreciated.

 

Background- Things were all fine when we were at 2018. * version, it started happening in 2019.1/ 2019.2 versions of Alteryx Server. I am fairly confident there are no issues with Cmd command triggering  AlteryxEngineCmd as I can always see that cmd prompt window. It starts with started running c:amhr.yxmd then it throws up that API error when unsuccessful.

 

API or Flowchart mode Error.pngEvent Config.PNG

 

Alteryx Partner

Hi @ujjwalstha ,

 

are you able to execute the workflow without scheduling and check if its still failing. Does the workflow have any macros.