community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

Unable to translate alias when scheduling workflows on Alteryx Server

Highlighted
Atom

Hi everyone,

 

I have created a workflow which uses a Input Data connection that reads a SQL server database. The connection is created in Alteryx Designer by selecting the connection from the Gallery. When saving the workflow to the Gallery, I set the workflow to use my specific credentials so that it can be scheduled.

Capture.PNG

When running the workflow in the Gallery manually, it works fine. However, if I schedule the workflow it suddenly complains to not be able to translate the alias as per the screenshot below

Capture1.png

 

I've read the troubleshooting guide but it does not seem to address this case, or am I missing something?

 

Regards,

Ronnie

Alteryx Certified Partner
Alteryx Certified Partner

If I'm not mistaken, the alias are both user and machine specific. Try scheduling this on your machine (with your credentials again) and see if that does the trick. If this works, you might need to configure the alias on the worker machine, or change the connection type to an ODBC.

Asteroid

Not sure if the Gallery connection is shared with the Studio you are part of, or if it is shared directly with you (as a User). I've faced similar issues: I (Curator) would share the connection with the Studio I'm part of, use that connection in my Designer and publish the workflow. When I ran the workflow manually from my Private Studio, it would run fine. But when I schedule it, I would get 'Unable to translate alias' error.

 

I then shared the connection directly with me (User not Studio), and I was able to schedule the workflow. Not sure if this is a bug or feature, but connections shared with Studios do not seem to work when workflows are scheduled, whereas connections shared directly with individual users seem to work when workflow are scheduled.

 

Hope this helps.

Atom

Yes, the connection was shared with the Studio and not directly to the users. Sharing the connection directly to the users solves the problem, thank you very much!

 

However, this feels like a workaround and not how it is intended to work?

This post saved me hours of headache and debugging.  I ran into this exact same issue and changed the permission on the Data Connection from using the studio to the individual user.  Thanks much for the help!

 

I echo @RonnieH 's comment about this being a bug.  Has this been reported to the Dev team?

Asteroid

@buddyboy00212  glad you found the solution helpful.

 

Yes, it seems to be a bug. One of the Alteryx engineers had confirmed that this is not how the feature was designed.

Alteryx
Alteryx

Hey all,

This is a known defect that we are planning to have resolved by early next year at the latest. The friction caused by having to share to each user individually is definitely something we want to get out of your way!

 

Thanks,

~Tanya
Alteryx Partner

I'm having the exact same issue. I have tried to remove my user and studio from the data connection on the server and add them both again. Unfortunately this didn't work. Any other suggestions?

Asteroid

@saugbjerg  Are you packaging the connection in the workflow while publishing, via Manage Workflow Assets option?

Alteryx Partner

Hi @AnupD - yes it appears that I've packaged the connection when uploading. If I deselect that under Workflow Assets, the conncetion doesn't work on the Gallery when I upload the workflow either. 

Then what on earth is going on then? I've selected the alias from the list of Saved Data Connections, so the alias on the server and in the desktop should be identical?